>>> ruby-net-imap: Building main/ruby-net-imap 0.5.15-r0 (using abuild 3.16.0-r0) started Tue, 27 Oct 2026 09:49:30 +0000 >>> ruby-net-imap: Validating /home/buildozer/aports/main/ruby-net-imap/APKBUILD... >>> ruby-net-imap: Analyzing dependencies... >>> ruby-net-imap: Installing for build: build-base ruby ruby-rdoc ruby-base64 ruby-rake ruby-test-unit ruby-test-unit-ruby-core ( 1/13) Installing ca-certificates (20261020-r0) ( 2/13) Installing libffi (3.5.2-r0) ( 3/13) Installing yaml (0.2.5-r2) ( 4/13) Installing ruby-libs (3.4.12-r0) ( 5/13) Installing libucontext (1.3.3-r0) ( 6/13) Installing ruby (3.4.12-r0) ( 7/13) Installing ruby-rdoc (3.4.12-r0) ( 8/13) Installing ruby-base64 (0.2.0-r1) ( 9/13) Installing ruby-rake (13.2.1-r1) (10/13) Installing ruby-power_assert (2.0.5-r0) (11/13) Installing ruby-test-unit (3.6.8-r0) (12/13) Installing ruby-test-unit-ruby-core (1.0.6-r0) (13/13) Installing .makedepends-ruby-net-imap (20261027.094932) Executing busybox-1.37.0-r30.trigger Executing ca-certificates-20261020-r0.trigger OK: 684.0 MiB in 117 packages >>> ruby-net-imap: Cleaning up srcdir >>> ruby-net-imap: Cleaning up pkgdir >>> ruby-net-imap: Cleaning up tmpdir >>> ruby-net-imap: Fetching https://distfiles.alpinelinux.org/distfiles/v3.23/net-imap-0.5.15.tar.gz Connecting to distfiles.alpinelinux.org (172.105.82.32:443) wget: server returned error: HTTP/1.1 404 Not Found >>> ruby-net-imap: Fetching https://github.com/ruby/net-imap/archive/v0.5.15/net-imap-0.5.15.tar.gz Connecting to github.com (140.82.121.4:443) Connecting to codeload.github.com (140.82.121.10:443) saving to '/var/cache/distfiles/v3.23/net-imap-0.5.15.tar.gz.part' net-imap-0.5.15.tar. 100% |********************************| 313k 0:00:00 ETA '/var/cache/distfiles/v3.23/net-imap-0.5.15.tar.gz.part' saved /var/cache/distfiles/v3.23/net-imap-0.5.15.tar.gz: OK /home/buildozer/aports/main/ruby-net-imap/gemspec.patch: OK >>> ruby-net-imap: Fetching https://distfiles.alpinelinux.org/distfiles/v3.23/net-imap-0.5.15.tar.gz /var/cache/distfiles/v3.23/net-imap-0.5.15.tar.gz: OK /home/buildozer/aports/main/ruby-net-imap/gemspec.patch: OK >>> ruby-net-imap: Unpacking /var/cache/distfiles/v3.23/net-imap-0.5.15.tar.gz... >>> ruby-net-imap: gemspec.patch patching file net-imap.gemspec WARNING: description and summary are identical WARNING: open-ended dependency on net-protocol (>= 0) is not recommended use a bounded requirement, such as "~> x.y" WARNING: open-ended dependency on date (>= 0) is not recommended use a bounded requirement, such as "~> x.y" WARNING: You have specified the uri: https://github.com/ruby/net-imap for all of the following keys: homepage_uri source_code_uri Only the first one will be shown on rubygems.org WARNING: See https://guides.rubygems.org/specification-reference/ for help Successfully built RubyGem Name: net-imap Version: 0.5.15 File: net-imap-0.5.15.gem /home/buildozer/aports/main/ruby-net-imap/src/net-imap-0.5.15/test/lib/profiling_helper.rb:10: warning: method redefined; discarding old profile? /home/buildozer/aports/main/ruby-net-imap/src/net-imap-0.5.15/test/lib/profiling_helper.rb:6: warning: previous definition of profile? was here Loaded suite /usr/lib/ruby/gems/3.4.0/gems/rake-13.2.1/lib/rake/rake_test_loader Started Net::IMAP::TestCase: AuthenticatorsTest: test: .authenticator mechanism name can be a symbol:.: (0.005920) test: .authenticator mechanism name is case insensitive: .: (0.002341) test: SASL::Authenticators.normalize_name: .: (0.002184) test_anonymous_length_over_255: .: (0.003716) test_anonymous_matches_mechanism: .: (0.001720) test_anonymous_response: .: (0.003047) test_anonymous_stringprep: .: (0.003264) test_cram_md5_authenticator: .: (0.006010) test_cram_md5_authenticator_deprecated: .: (0.002782) test_cram_md5_authenticator_matches_mechanism: .: (0.002416) test_cram_md5_does_not_support_initial_response: .: (0.002142) test_digest_md5_authenticator: .: (0.013017) test_digest_md5_authenticator_deprecated: .: (0.003881) test_digest_md5_authenticator_empty_challenge: .: (0.004198) test_digest_md5_authenticator_empty_challenge_commas: .: (0.005358) test_digest_md5_authenticator_empty_qop: .: (0.005467) test_digest_md5_authenticator_garbage: .: (0.004932) test_digest_md5_authenticator_garbage_no_equal_sign:.: (0.004689) test_digest_md5_authenticator_illinear: .: (0.048993) test_digest_md5_authenticator_matches_mechanism: .: (0.002612) test_digest_md5_authenticator_missing_nonce: .: (0.005430) test_digest_md5_authenticator_qdstr_with_comma: .: (0.004605) test_digest_md5_authenticator_realm_and_digest_uri: .: (0.003833) test_digest_md5_does_not_support_initial_response: .: (0.002517) test_external_invalid: .: (0.002590) test_external_matches_mechanism: .: (0.001826) test_external_response: .: (0.002359) test_external_utf8: .: (0.001369) test_login_authenticator_deprecated: .: (0.001744) test_login_authenticator_matches_mechanism: .: (0.001358) test_login_does_not_support_initial_response: .: (0.001244) test_login_responses: .: (0.001432) test_net_imap_authenticator_deprecated: .: (0.002821) test_oauthbearer_authenticator_matches_mechanism: .: (0.001829) test_oauthbearer_response: .: (0.003609) test_plain_authenticator_matches_mechanism: .: (0.001358) test_plain_authzid: .: (0.001583) test_plain_kw_params: .: (0.001415) test_plain_no_null_chars: .: (0.004885) test_plain_response: .: (0.001104) test_plain_supports_initial_response: .: (0.001259) test_plain_username_kw_sets_both_authcid_and_authzid: .: (0.001161) test_scram_kwargs: .: (0.002088) test_scram_max_iterations: .: (0.008135) test_scram_min_iterations: .: (0.007063) test_scram_sha1_authenticator: .: (0.018192) test_scram_sha1_authenticator_matches_mechanism: .: (0.001625) test_scram_sha256_authenticator: .: (0.020865) test_scram_sha256_authenticator_matches_mechanism: .: (0.001770) test_xoauth2_authenticator_matches_mechanism: .: (0.001595) test_xoauth2_kwargs: .: (0.001983) test_xoauth2_response: .: (0.001318) test_xoauth2_supports_initial_response: .: (0.001320) CommandDataTest: test: Atom: .: (0.020572) test: Flag: .: (0.016031) test: Literal: .: (0.003779) test: Literal8: .: (0.002456) QuotedStringTest: test: ASCII compatible string with another encodings: .: (0.003533) test: allows ASCII control chars: .: (0.001515) test: escapes quoted specials: .: (0.002558) test: invalid ASCII byte[NULL]: .: (0.007241) test: invalid ASCII byte[CR]: .: (0.007078) test: invalid ASCII byte[LF]: .: (0.006853) test: invalid UTF-8[incomplete 2 byte sequence]: .: (0.010016) test: invalid UTF-8[invalid 2 byte sequence]: .: (0.009113) test: invalid UTF-8[incomplete 3 byte sequence]: .: (0.007163) test: invalid UTF-8[invalid 3 byte sequence]: .: (0.006648) test: invalid UTF-8[incomplete 4 byte sequence]: .: (0.008054) test: invalid UTF-8[invalid 4 byte sequence]: .: (0.007664) test: invalid UTF-8[first byte too high]: .: (0.006892) test: invalid UTF-8[UTF-16 surrogate pair]: .: (0.006878) test: invalid UTF-8[windows-1252]: .: (0.006342) test: quotes ASCII strings (atom specials): .: (0.003087) test: quotes ASCII strings (no specials): .: (0.002347) test: quotes valid UTF-8 multibyte chars: .: (0.001720) RawDataTest: test: .split[simple raw text]: .: (0.002989) test: .split[text, literal, text]: .: (0.002850) test: .split[empty literals]: .: (0.002882) test: .split[binary and regular]: .: (0.002256) test: .split allows final literal prefix: .: (0.003946) test: a single literal: .: (0.002074) test: binary literal with regular literal: .: (0.002529) test: empty literals: .: (0.002569) test: invalid bytes in raw text[CR]: .: (0.003285) test: invalid bytes in raw text[LF]: .: (0.002729) test: invalid bytes in raw text[NULL]: .: (0.002259) test: invalid bytes in raw text[CRLF]: .: (0.002298) test: invalid literal ending ('{123}'): .: (0.008593) test: literals embedded between text: .: (0.002644) test: raw text embedded between literals: .: (0.002427) test: raw text followed by literal: .: (0.002648) test: simple raw text: .: (0.001953) RawTextTest: test: ASCII compatible string with another encodings: .: (0.003535) test: allows ASCII control chars: .: (0.001442) test: allows ASCII strings with no specials: .: (0.002152) test: allows atom specials: .: (0.002181) test: allows quoted specials: .: (0.001656) test: allows valid UTF-8 multibyte chars: .: (0.001708) test: invalid ASCII byte[NULL]: .: (0.007487) test: invalid ASCII byte[CR]: .: (0.007291) test: invalid ASCII byte[LF]: .: (0.007763) test: invalid UTF-8[incomplete 2 byte sequence]: .: (0.007340) test: invalid UTF-8[invalid 2 byte sequence]: .: (0.007299) test: invalid UTF-8[incomplete 3 byte sequence]: .: (0.008511) test: invalid UTF-8[invalid 3 byte sequence]: .: (0.008373) test: invalid UTF-8[incomplete 4 byte sequence]: .: (0.008642) test: invalid UTF-8[invalid 4 byte sequence]: .: (0.007225) test: invalid UTF-8[first byte too high]: .: (0.006484) test: invalid UTF-8[UTF-16 surrogate pair]: .: (0.006761) test: invalid UTF-8[windows-1252]: .: (0.006881) ConfigTest: test: #clone: .: (0.004535) test: #debug: .: (0.003956) test: #dup: .: (0.002260) test: #freeze: .: (0.001952) test: #inherited? and #reset(attr): .: (0.003048) test: #load_defaults: .: (0.006544) test: #max_response_size=(Integer | nil): .: (0.002534) test: #new and inheritance: .: (0.003059) test: #reset all attributes: .: (0.001749) test: #to_h: .: (0.002138) test: #update: .: (0.001444) test: #update with invalid key name: .: (0.002902) test: #update with invalid value: .: (0.001978) test: #with: .: (0.003766) test: .[] for all version_defaults: .: (0.003866) test: .[] for all x.y versions: .: (0.006075) test: .[] key errors: .: (0.003421) test: .[] range errors: .: (0.003796) test: .[] with a hash: .: (0.002067) test: .[] with object responding to to_sym, to_r, or to_f: .: (0.003805) test: .[] with string names: .: (0.001857) test: .[] with symbol names: .: (0.002370) test: .default: .: (0.001614) test: .global: .: (0.002236) test: .new always sets a parent: .: (0.002686) test: .new(parent, ...) and inheritance: .: (0.004097) test: .version_defaults are all frozen, and inherit debug from global: .: (0.053262) test: Config[:default] and Config[:current] both hold default config: .: (0.001940) test: Net::IMAP.config: .: (0.001078) test: boolean type constraints and conversion: .: (0.001626) test: enum type constraint: .: (0.003857) test: integer type constraints and conversion: .: (0.002692) ConnectionStateTest: test: #authenticated?: .: (0.003251) test: #deconstruct: .: (0.001906) test: #deconstruct_keys: .: (0.003331) test: #logout?: .: (0.001692) test: #name: .: (0.001793) test: #not_authenticated?: .: (0.001573) test: #selected?: .: (0.001904) test: #to_sym: .: (0.002291) DataEncodingTest: test_decode_date: .: (0.003794) test_decode_datetime: .: (0.002542) test_decode_time: .: (0.003625) test_decode_utf7: .: (0.038318) test_encode_date: .: (0.001984) test_encode_datetime: .: (0.001476) test_encode_utf7: .: (0.011602) ESearchResultTest: test: #data.assoc('UNKNOWN') returns ExtensionData value: .: (0.013383) test: #each: .: (0.004640) test: #partial returns PARTIAL value (RFC9394: PARTIAL): .: (0.005769) test: #tag: .: (0.002016) test: #to_a: .: (0.003898) test: #to_sequence_set: .: (0.004606) test: #uid: .: (0.001884) test: simple RFC4731 and RFC9051 return data accessors: .: (0.002385) FetchDataTest: test: #binary(1, 2, 3, offset: 1) returns the BINARY[1.2.3]<1> attr:.: (0.002796) test: #binary_size(1, 2, 3) returns the BINARY.SIZE[1.2.3] attr: .: (0.001736) test: #emailid returns EMAILID value (RFC8474: OBJECTID): .: (0.001903) test: #header returns the BODY[HEADER] attr: .: (0.001114) test: #header(1, 2, 3) returns the BODY[1.2.3.HEADER] attr: .: (0.001312) test: #header(1, 2, oFfset: 456) returns the BODY[1.2.HEADER]<456> attr: .: (0.001205) test: #header_fields(*) => BODY[HEADER.FIELDS (*)] attr: .: (0.001893) test: #header_fields(*, offset:) => BODY[part.HEADER.FIELDS (*)]: .: (0.001823) test: #header_fields(*, part:) => BODY[part.HEADER.FIELDS (*)] attr:.: (0.002134) test: #header_fields_not(*) => BODY[HEADER.FIELDS.NOT (*)] attr: .: (0.001340) test: #header_fields_not(*, offset:) => BODY[part.HEADER.FIELDS.NOT (*)]: .: (0.001508) test: #header_fields_not(*, part:) => BODY[part.HEADER.FIELDS.NOT (*)] attr:.: (0.002167) test: #internaldate parses a datetime value: .: (0.007752) test: #message returns the BODY[] attr: .: (0.001962) test: #message(offset:) returns the BODY[] attr: .: (0.001085) test: #mime(1, 2, 3) returns the BODY[1.2.3.MIME] attr: .: (0.001298) test: #mime(1, 2, oFfset: 456) returns the BODY[1.2.MIME]<456> attr:.: (0.001343) test: #modseq returns MODSEQ value (RFC7162: CONDSTORE): .: (0.001105) test: #part(1, 2, 3) returns the BODY[1.2.3] attr: .: (0.001366) test: #part(1, 2, oFfset: 456) returns the BODY[1.2]<456> attr: .: (0.001168) test: #seqno: .: (0.001515) test: #text returns the BODY[TEXT] attr: .: (0.001440) test: #text(1, 2, 3) returns the BODY[1.2.3.TEXT] attr: .: (0.001611) test: #text(1, 2, 3, oFfset: 456) returns the BODY[1.2.3.TEXT]<456> attr: .: (0.001402) test: #threadid returns THREADID value (RFC8474: OBJECTID): .: (0.001812) test: #uid: .: (0.001345) test: simple RFC3501 and RFC9051 attrs accessors: .: (0.002812) test: simple RFC822 attrs accessors (deprecated by RFC9051):.: (0.001558) IMAPAuthenticateTest: test: #authenticate disconnects and raises SASL::AuthenticationFailed when the server succeeds prematurely: .: (0.089329) test: #authenticate never sends an initial response when config.sasl_ir: false: .: (0.147871) test: #authenticate never sends an initial response when sasl_ir: false: .: (0.150014) test: #authenticate never sends an initial response when the mechanism does not support client-first: .: (0.077599) test: #authenticate never sends an initial response when the server doesn't explicitly support the mechanism: .: (0.095217) test: #authenticate never sends an initial response when the server isn't capable: .: (0.086310) test: #authenticate sends '=' as the initial reponse when the initial response is an empty string: .: (0.189433) test: #authenticate sends an initial response when supported by both the mechanism and the server: .: (0.073792) IMAPCapabilitiesTest: test: #auth_capable?(name) checks cached capabilities for AUTH=name:.: (0.130999) test: #auth_mechanisms reports cached capabilities with AUTH={name}:.: (0.119875) test: #capabilities cache IGNORES tagged OK response to STARTTLS: .: (0.236356) test: #capabilities cache is NOT cleared after #authenticate fails: .: (0.207158) test: #capabilities cache is NOT cleared after #login fails:.: (0.073831) test: #capabilities cache is cleared after #authenticate: .: (0.166196) test: #capabilities cache is cleared after #login: .: (0.517444) test: #capabilities cache is cleared after #starttls: .: (0.225194) test: #capabilities cache is retained after selecting a mailbox: .: (0.122635) test: #capabilities caches greeting capabilities (PREAUTH): .: (0.027632) test: #capabilities caches greeting capabilities (cleartext): .: (0.031421) test: #capabilities caches greeting capabilities (implicit TLS): .: (0.219821) test: #capabilities caches tagged OK response to AUTHENTICATE: .: (0.080675) test: #capabilities caches tagged OK response to LOGIN: .: (0.073055) test: #capabilities returns cached CAPABILITY data: .: (0.116212) test: #capability caches its result: .: (0.109042) test: #capable?(name) checks cached CAPABILITY data for name: .: (0.121254) test: #clear_cached_capabilities clears cached capabilities:.: (0.115585) IMAPConnectionStateTest: test: #connection_state after #disconnect: .: (0.023435) test: #connection_state after #logout: .: (0.025649) test: #connection_state after #logout!: .: (0.026050) test: #connection_state after AUTHENTICATE, SELECT, CLOSE successes:.: (0.209363) test: #connection_state after LOGIN, EXAMINE, UNSELECT successes: .: (0.289493) test: #connection_state after PREAUTH: .: (0.162100) test: #connection_state after [CLOSED] response code: .: (0.247443) test: #connection_state after failed LOGIN or AUTHENTICATE: .: (0.207914) test: #connection_state after failed SELECT or EXAMINE: .: (0.301063) IMAPDeprecatedClientOptionsTest: InitializeTests: test: Convert deprecated usessl (= false) with warning: .: (0.021810) test: Convert deprecated usessl (= true) and certs, with warning: .: (0.204719) test: Convert deprecated usessl (= true) and verify (= false), with warning: .: (0.211982) test: Convert obsolete options hash to keywords: .: (0.023172) test: Convert obsolete port argument to :port keyword: .: (0.019196) test: combined options hash and keyword args raises ArgumentError:.: (0.002228) test: combined options hash and ssl args raises ArgumentError: .: (0.002578) StartTLSTests: test: Convert deprecated certs, verify with warning: .: (0.151411) test: Convert obsolete options hash to keywords: .: (0.135903) test: combined options hash and keyword args raises ArgumentError:.: (0.028460) test: combined options hash and ssl args raises ArgumentError: .: (0.031623) IMAPEnableTest: test: missing server ENABLED response: .: (0.073689) test_enable: .: (0.297662) IMAPErrorsTest: test: ResponseTooLargeError: .: (0.010689) IMAPExpungeTest: test: #expunge with EXPUNGE responses: .: (0.209945) test: #expunge with a VANISHED response: .: (0.215519) test: #expunge with multiple VANISHED responses: .: (0.218924) test: #uid_expunge with EXPUNGE responses: .: (0.206080) test: #uid_expunge with VANISHED response: .: (0.204917) IMAPFetchTest: test: #fetch with FETCH responses: .: (0.215971) test: #fetch with changedsince: .: (0.165953) test: #uid_fetch with UIDFETCH responses: .: (0.248244) test: #uid_fetch with changedsince: .: (0.163137) test: #uid_fetch with partial: .: (0.352780) test: argument errors: .: (0.124672) IMAPLoginTest: test: #login doesn't send CAPABILITY when it is already cached: .: (0.072518) test: #login first checks capabilities for LOGINDISABLED (failure): .: (0.113084) test: #login first checks capabilities for LOGINDISABLED (success): .: (0.153913) test: #login raises LoginDisabledError when LOGINDISABLED: .: (0.027265) test: #login raises LoginDisabledError without sending CAPABILITY when config.enforce_logindisabled is :when_capabilities_cached: .: (0.035430) test: #login sends LOGIN without asking CAPABILITY when config.enforce_logindisabled is :when_capabilities_cached: .: (0.145863) test: #login sends LOGIN without asking CAPABILITY when config.enforce_logindisabled is false: .: (0.071371) IMAPMaxResponseSizeTest: test: #max_response_size closes connection for too long line: .: (0.026221) test: #max_response_size closes connection for too long literal: .: (0.030454) test: #max_response_size reading literals: .: (0.076771) IMAPQuotaTest: test: #setquota(quota_root, limit): .: (0.172622) IMAPRegexpsTest: test_linear_time[Net::IMAP::FakeServer::Socket#ignore_closed?: /stream closed|closed stream/i]: .: (0.003847) test_linear_time[Net::IMAP::FakeServer::CommandReader#get_command: /\{(\d+)(\+)?\}\r\n\z/n]:.: (0.001242) test_linear_time[Net::IMAP::FakeServer::CommandReader#scan_astrings: /"((?:[^"\\]|\\["\\])+)"|(\S+)/n]: .: (0.002677) test_linear_time[Net::IMAP::FakeServer::CommandReader#scan_astrings: /\\([\\"])/n]: .: (0.001742) test_linear_time[Net::IMAP::FakeServer::CommandReader#partial_parse: /\A([^ ]+) ((?:UID )?\w+)(?: (.+))?\r\n\z/min]:.: (0.001470) test_linear_time[Net::IMAP::FakeServer::CommandReader#parse: /\A([^ ]+) ((?:UID )?\w+)(?: (.+))?\r\n\z/min]:.: (0.001305) test_linear_time[Net::IMAP::FakeServer::ResponseWriter#resp_code: /\A\[/]: .: (0.001186) test_linear_time[Net::IMAP::RawData.split: /(~)?\{(0|[1-9]\d*)(\+)?\}\r\n/n]: .: (0.002716) test_linear_time[Net::IMAP::RawData#validate: /\{\d+\+?\}\z/n]: .: (0.001125) test_linear_time[Net::IMAP::StringPrep::Tables::IN_A_1]: .: (0.001518) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_1]: .: (0.001535) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_2]: .: (0.001525) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_3]: .: (0.001288) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_1_1]: .: (0.001162) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_1_2]: .: (0.004397) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_2_1]: .: (0.001347) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_2_2]: .: (0.001395) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_3]: .: (0.001634) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_4]: .: (0.001232) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_5]: .: (0.001130) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_6]: .: (0.002167) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_7]: .: (0.001182) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_8]: .: (0.001985) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_9]: .: (0.001486) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_1]: .: (0.001204) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_1_NEGATED]: .: (0.001532) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_2]: .: (0.001509) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILS_REQ3]: .: (0.001763) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILS_REQ2]: .: (0.002104) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILURE]: .: (0.002758) test_linear_time[Net::IMAP::StringPrep::SASLprep::MAP_TO_SPACE]: .: (0.002049) test_linear_time[Net::IMAP::StringPrep::SASLprep::MAP_TO_NOTHING]: .: (0.001531) test_linear_time[Net::IMAP::StringPrep::SASLprep::PROHIBITED_STORED]: .: (0.002216) test_linear_time[Net::IMAP::StringPrep::SASLprep::PROHIBITED]: .: (0.002430) test_linear_time[Net::IMAP::StringPrep::SASLprep::ASCII_NO_CTRLS]: .: (0.001246) test_linear_time[Net::IMAP::StringPrep::SASLprep.saslprep: /invalid byte sequence|incompatible encoding/]: .: (0.001743) test_linear_time[Net::IMAP::StringPrep::SASLprep#saslprep: /invalid byte sequence|incompatible encoding/]: .: (0.001220) test_linear_time[Net::IMAP::StringPrep.check_prohibited!: /^C/]: .: (0.001536) test_linear_time[Net::IMAP::StringPrep#check_prohibited!: /^C/]: .: (0.001291) test_linear_time[Net::IMAP::ValidNonLiteralData#validate: /[\r\n]/]:.: (0.001192) test_linear_time[Net::IMAP::SASL::Authenticators#add_authenticator: /[^a-zA-Z0-9]/]:.: (0.001841) test_linear_time[Net::IMAP::SASL::GS2Header::NO_NULL_CHARS]:.: (0.001111) test_linear_time[Net::IMAP::SASL::GS2Header::RFC5801_SASLNAME]: .: (0.001293) test_linear_time[Net::IMAP::SASL::ExternalAuthenticator#initialize: /\u0000/]: .: (0.001074) test_linear_time[Net::IMAP::SASL::ScramAuthenticator#parse_challenge: /,/]: .: (0.001382) test_linear_time[Net::IMAP::SASL::ScramAuthenticator#parse_challenge: /=/]: .: (0.001254) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#process: /rspauth=/]: .: (0.001257) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#compute_a2: /^auth-(?:conf|int)$/]:.: (0.001020) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#parse_challenge: /\A"(.*)"\z/mn]: .: (0.001320) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#parse_challenge: /\\(.)/mn]: .: (0.001058) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#qdval: /([\\"])/]: .: (0.001589) test_linear_time[Net::IMAP::QuotedString#formatted: /["\\]/]: .: (0.001140) test_linear_time[Net::IMAP::StringFormatter::LITERAL_REGEX]:.: (0.001092) test_linear_time[Net::IMAP::SequenceSet#number_input?: /[:,]/]: .: (0.001359) test_linear_time[Net::IMAP::SequenceSet#nz_number: /\A[1-9]\d*\z/]: .: (0.001352) test_linear_time[Net::IMAP::Config::AttrAccessors.attributes: /=\z/]: .: (0.001421) test_linear_time[Net::IMAP::ResponseParser::ParserUtils::Generator#def_char_matchers: /\A[A-Z]/]: .: (0.001569) test_linear_time[Net::IMAP::ResponseParser::ParserUtils::Generator#def_token_matchers: /\A[A-Z]/]: .: (0.001668) test_linear_time[Net::IMAP::ResponseParser::ADDRESS_REGEXP]:.: (0.002046) test_linear_time[Net::IMAP::ResponseParser::RE_RESPONSE_TYPE]: .: (0.002644) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE]: .: (0.002200) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::OCTET]: .: (0.001534) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::SP]: .: (0.001802) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CHAR]: .: (0.001731) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::ALPHA]: .: (0.001881) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CTL]:.: (0.001393) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::DIGIT]: .: (0.001728) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CRLF]: .: (0.001116) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::DQUOTE]: .: (0.001284) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::HEXDIG]: .: (0.001793) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_1]: .: (0.001089) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_TAIL]: .: (0.001684) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_2]: .: (0.001367) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_3]: .: (0.001433) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_4]: .: (0.001865) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_CHAR]: .: (0.001394) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_OCTETS]:.: (0.001287) test_linear_time[Net::IMAP::ResponseParser::Patterns::CHAR8]: .: (0.001290) test_linear_time[Net::IMAP::ResponseParser::Patterns::LIST_WILDCARDS]: .: (0.001541) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_SPECIALS]: .: (0.001444) test_linear_time[Net::IMAP::ResponseParser::Patterns::RESP_SPECIALS]: .: (0.001414) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_SPECIALS]: .: (0.001790) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_CHAR]:.: (0.001127) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM_CHAR]: .: (0.001350) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM]:.: (0.001413) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_CHARS]: .: (0.001031) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOMISH]: .: (0.001630) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAG]: .: (0.001615) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_CHAR]: .: (0.001152) test_linear_time[Net::IMAP::ResponseParser::Patterns::CODE_TEXT_CHAR]: .: (0.001539) test_linear_time[Net::IMAP::ResponseParser::Patterns::CODE_TEXT]: .: (0.001237) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG]:.: (0.001595) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_EXTENSION]: .: (0.001205) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_KEYWORD]:.: (0.001403) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_PERM]: .: (0.001513) test_linear_time[Net::IMAP::ResponseParser::Patterns::MBX_FLAG]: .: (0.001090) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_LIST]: .: (0.001226) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_PERM_LIST]: .: (0.001612) test_linear_time[Net::IMAP::ResponseParser::Patterns::MBX_LIST_FLAGS]: .: (0.001450) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUIRKY_FLAG]: .: (0.001367) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUIRKY_FLAGS_LIST]: .: (0.001320) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_safe]: .: (0.001717) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_esc]: .: (0.001328) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_rev1]: .: (0.001051) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_rev2]: .: (0.001610) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_rev1]: .: (0.001524) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_rev2]: .: (0.001297) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_rev1]: .: (0.001731) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_rev2]: .: (0.001272) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_LABEL_FCHAR]: .: (0.001193) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_LABEL_CHAR]: .: (0.001386) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_EXT_LABEL]: .: (0.001516) test_linear_time[Net::IMAP::ResponseParser::Patterns::NZ_NUMBER]: .: (0.001257) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQ_NUMBER]: .: (0.001235) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQ_RANGE]: .: (0.001101) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET_ITEM]: .: (0.001544) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET]:.: (0.001153) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET_STR]: .: (0.001093) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE_FIRST]: .: (0.001662) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE_LAST]: .: (0.001230) test_linear_time[Net::IMAP::ResponseParser::Patterns::LITERAL]: .: (0.001417) test_linear_time[Net::IMAP::ResponseParser::Patterns::LITERAL8]: .: (0.001178) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM_SPECIALS]: .: (0.001321) test_linear_time[Net::IMAP::ResponseParser::SPACES_REGEXP]: .: (0.001307) test_linear_time[Net::IMAP::ResponseParser::BEG_REGEXP]: .: (0.001370) test_linear_time[Net::IMAP::ResponseParser::DATA_REGEXP]: .: (0.001473) test_linear_time[Net::IMAP::ResponseParser::TEXT_REGEXP]: .: (0.001537) test_linear_time[Net::IMAP::ResponseParser::CTEXT_REGEXP]: .: (0.001199) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABODY\[/in]: .: (0.001368) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABINARY\[/in]:.: (0.001641) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABINARY\.SIZE\[/in]: .: (0.001079) test_linear_time[Net::IMAP::ResponseParser#msg_att__label: /\A(?:RFC822(?:\.HEADER|\.TEXT)?)\z/in]: .: (0.001263) test_linear_time[Net::IMAP::ResponseParser#body_type_1part: /\G(?: (? "TEXT" \s "[^"]+" ) |(? "MESSAGE" \s "(?:RFC822|GLOBAL)" ) |(? "[^"]+" \s "[^"]+" ) |(? "MIXED" ) )/ixn]: .: (0.001446) test_linear_time[Net::IMAP::ResponseParser#esearch_response: /\G UID\b/i]: .: (0.001325) test_linear_time[Net::IMAP::ResponseParser#next_token: /\S*/n]: .: (0.001240) test_linear_time[Net::IMAP::ResponseReader#get_literal_size: /\{(\d+)\}\r\n\z/n]: .: (0.001414) test_linear_time[Net::IMAP::TestData#test_memberless: /#/]: .: (0.001198) test_linear_time[Net::IMAP::TestData#test_define_edge_cases: /duplicate member/]: .: (0.001294) test_linear_time[Net::IMAP.decode_utf7: /&([A-Za-z0-9+,]+)?-/n]: .: (0.001556) test_linear_time[Net::IMAP.encode_utf7: /(&)|[^\x20-\x7e]+/]: .: (0.001270) test_linear_time[Net::IMAP#auth_mechanisms: /\AAUTH=/i]: .: (0.001435) test_linear_time[Net::IMAP#enable: / /]: .: (0.001077) test_linear_time[Net::IMAP#put_string: /\n/n]: .: (0.001574) test_linear_time[Net::IMAP#put_string: /\n\z/n]: .: (0.001156) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:OK)\z/in]: .: (0.001095) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:NO)\z/in]: .: (0.001348) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:BAD)\z/in]: .: (0.001199) test_linear_time[Net::IMAP#get_response: /^/n]: .: (0.001115) test_linear_time[Net::IMAP#search_args: /\ACHARSET\b/i]: .: (0.001263) test_linear_time[Net::IMAP#search_args: /\ACHARSET\z/i]: .: (0.001117) test_linear_time[Net::IMAP#send_string_data: /[\r\n]/n]: .: (0.001705) test_linear_time[Net::IMAP#send_string_data: /[(){ \x00-\x1f\x7f%*"\\]/n]: .: (0.001371) test_linear_time[Net::IMAP#send_quoted_string: /["\\]/]: .: (0.001115) IMAPResponseHandlersTest: test: #add_response_handlers: .: (0.371779) test: ::new with response_handlers kwarg: .: (0.111774) IMAPResponsesTest: test: #clear_responses: .: (0.117360) test: #extract_responses: .: (0.133986) test: #responses without type or block: .: (0.041910) test: #responses(&block): .: (0.126264) test: #responses(type, &block): .: (0.127445) test: #responses(type, &nil): .: (0.133744) IMAPSearchTest: test: #search/#uid_search: .: (1.537921) test: #search/#uid_search with ESEARCH or IMAP4rev2:.: (0.137211) test: #search/#uid_search with invalid arguments: .: (0.029700) test: missing server ESEARCH response: .: (0.115534) test: missing server SEARCH response: .: (0.116496) test: missing server SORT response: .: (0.119265) test: missing server THREAD response: .: (0.125259) IMAPSelectTest: test: #examine with condstore: .: (0.120951) test: #select with condstore: .: (0.124203) test_close: .: (0.163701) test_unselect: .: (0.167586) IMAPSequenceSetTest: test: #<<: .: (0.008323) test: #== equality by value (not by identity or representation): .: (0.003888) test: #[negative index]: .: (0.010895) test: #[non-negative index]: .: (0.007930) test: #[range]: .: (0.221490) test: #[start, length]: .: (0.109737) test: #above: .: (0.010428) test: #add: .: (0.005744) test: #add?: .: (0.006372) test: #append: .: (0.009750) test: #at(negative index): .: (0.008260) test: #at(non-negative index): .: (0.007382) test: #below: .: (0.011213) test: #clone: .: (0.003402) test: #clone preserves ractor sharability (deeply frozen): .: (0.001958) test: #count[single number]: .: (0.001478) test: #count[single range]: .: (0.001777) test: #count[simple numbers list]: .: (0.001306) test: #count[numbers and ranges list]: .: (0.001727) test: #count[just *]: .: (0.001433) test: #count[range with *]: .: (0.001265) test: #count[* sorts last]: .: (0.001824) test: #count[out of order]: .: (0.001646) test: #count[adjacent]: .: (0.001854) test: #count[overlapping]: .: (0.001624) test: #count[contained]: .: (0.001745) test: #count[multiple *]: .: (0.001640) test: #count[array]: .: (0.002072) test: #count[nested array]: .: (0.002161) test: #count[Set]: .: (0.001771) test: #count[empty]: .: (0.001359) test: #count_duplicates[single number]: .: (0.001610) test: #count_duplicates[single range]: .: (0.001922) test: #count_duplicates[simple numbers list]: .: (0.001790) test: #count_duplicates[numbers and ranges list]: .: (0.002554) test: #count_duplicates[just *]: .: (0.001926) test: #count_duplicates[range with *]: .: (0.002075) test: #count_duplicates[* sorts last]: .: (0.001790) test: #count_duplicates[out of order]: .: (0.002074) test: #count_duplicates[adjacent]: .: (0.002574) test: #count_duplicates[overlapping]: .: (0.002788) test: #count_duplicates[contained]: .: (0.002508) test: #count_duplicates[multiple *]: .: (0.001942) test: #count_duplicates[array]: .: (0.002081) test: #count_duplicates[nested array]: .: (0.002147) test: #count_duplicates[Set]: .: (0.001808) test: #count_duplicates[empty]: .: (0.001174) test: #count_with_duplicates[single number]: .: (0.001647) test: #count_with_duplicates[single range]: .: (0.002084) test: #count_with_duplicates[simple numbers list]: .: (0.001830) test: #count_with_duplicates[numbers and ranges list]: .: (0.002573) test: #count_with_duplicates[just *]: .: (0.001247) test: #count_with_duplicates[range with *]: .: (0.001517) test: #count_with_duplicates[* sorts last]: .: (0.001616) test: #count_with_duplicates[out of order]: .: (0.002429) test: #count_with_duplicates[adjacent]: .: (0.002164) test: #count_with_duplicates[overlapping]: .: (0.002241) test: #count_with_duplicates[contained]: .: (0.002137) test: #count_with_duplicates[multiple *]: .: (0.002225) test: #count_with_duplicates[array]: .: (0.001907) test: #count_with_duplicates[nested array]: .: (0.002231) test: #count_with_duplicates[Set]: .: (0.001671) test: #count_with_duplicates[empty]: .: (0.001164) test: #cover?: .: (0.071738) test: #deconstruct[single number]: .: (0.002167) test: #deconstruct[single range]: .: (0.001580) test: #deconstruct[simple numbers list]: .: (0.002059) test: #deconstruct[numbers and ranges list]: .: (0.001925) test: #deconstruct[just *]: .: (0.001584) test: #deconstruct[range with *]: .: (0.001688) test: #deconstruct[* sorts last]: .: (0.001884) test: #deconstruct[out of order]: .: (0.001938) test: #deconstruct[adjacent]: .: (0.002024) test: #deconstruct[overlapping]: .: (0.002210) test: #deconstruct[contained]: .: (0.002311) test: #deconstruct[multiple *]: .: (0.001778) test: #deconstruct[array]: .: (0.002697) test: #deconstruct[nested array]: .: (0.002710) test: #deconstruct[Set]: .: (0.002399) test: #deconstruct[empty]: .: (0.001224) test: #delete: .: (0.012955) test: #delete?: .: (0.010180) test: #delete_at: .: (0.006475) test: #disjoint?: .: (0.004166) test: #dup: .: (0.003988) test: #each_element[single number]: .: (0.002389) test: #each_element[single range]: .: (0.002547) test: #each_element[simple numbers list]: .: (0.002278) test: #each_element[numbers and ranges list]: .: (0.002672) test: #each_element[just *]: .: (0.002001) test: #each_element[range with *]: .: (0.002835) test: #each_element[* sorts last]: .: (0.002529) test: #each_element[out of order]: .: (0.002998) test: #each_element[adjacent]: .: (0.002912) test: #each_element[overlapping]: .: (0.002925) test: #each_element[contained]: .: (0.002319) test: #each_element[multiple *]: .: (0.002484) test: #each_element[array]: .: (0.003449) test: #each_element[nested array]: .: (0.004163) test: #each_element[Set]: .: (0.003045) test: #each_element[empty]: .: (0.001898) test: #each_entry[single number]: .: (0.002935) test: #each_entry[single range]: .: (0.002676) test: #each_entry[simple numbers list]: .: (0.003072) test: #each_entry[numbers and ranges list]: .: (0.003906) test: #each_entry[just *]: .: (0.001954) test: #each_entry[range with *]: .: (0.002886) test: #each_entry[* sorts last]: .: (0.002683) test: #each_entry[out of order]: .: (0.003743) test: #each_entry[adjacent]: .: (0.004542) test: #each_entry[overlapping]: .: (0.004801) test: #each_entry[contained]: .: (0.003973) test: #each_entry[multiple *]: .: (0.003010) test: #each_entry[array]: .: (0.003886) test: #each_entry[nested array]: .: (0.004030) test: #each_entry[Set]: .: (0.003718) test: #each_entry[empty]: .: (0.001948) test: #each_number[single number]: .: (0.002164) test: #each_number[single range]: .: (0.002269) test: #each_number[simple numbers list]: .: (0.002502) test: #each_number[numbers and ranges list]: .: (0.003067) test: #each_number[just *]: .: (0.002891) test: #each_number[range with *]: .: (0.002537) test: #each_number[* sorts last]: .: (0.002925) test: #each_number[out of order]: .: (0.003019) test: #each_number[adjacent]: .: (0.003043) test: #each_number[overlapping]: .: (0.003140) test: #each_number[contained]: .: (0.003396) test: #each_number[multiple *]: .: (0.002817) test: #each_number[array]: .: (0.003692) test: #each_number[nested array]: .: (0.003615) test: #each_number[Set]: .: (0.002995) test: #each_number[empty]: .: (0.002069) test: #each_ordered_number[single number]: .: (0.002830) test: #each_ordered_number[single range]: .: (0.003175) test: #each_ordered_number[simple numbers list]: .: (0.003610) test: #each_ordered_number[numbers and ranges list]:.: (0.004376) test: #each_ordered_number[just *]: .: (0.002659) test: #each_ordered_number[range with *]: .: (0.002919) test: #each_ordered_number[* sorts last]: .: (0.002462) test: #each_ordered_number[out of order]: .: (0.003985) test: #each_ordered_number[adjacent]: .: (0.004725) test: #each_ordered_number[overlapping]: .: (0.004065) test: #each_ordered_number[contained]: .: (0.004178) test: #each_ordered_number[multiple *]: .: (0.002584) test: #each_ordered_number[array]: .: (0.003348) test: #each_ordered_number[nested array]: .: (0.003555) test: #each_ordered_number[Set]: .: (0.003180) test: #each_ordered_number[empty]: .: (0.001791) test: #each_range[single number]: .: (0.002082) test: #each_range[single range]: .: (0.002447) test: #each_range[simple numbers list]: .: (0.002078) test: #each_range[numbers and ranges list]: .: (0.002324) test: #each_range[just *]: .: (0.002187) test: #each_range[range with *]: .: (0.002237) test: #each_range[* sorts last]: .: (0.002844) test: #each_range[out of order]: .: (0.002637) test: #each_range[adjacent]: .: (0.002983) test: #each_range[overlapping]: .: (0.002924) test: #each_range[contained]: .: (0.002368) test: #each_range[multiple *]: .: (0.002615) test: #each_range[array]: .: (0.003742) test: #each_range[nested array]: .: (0.003430) test: #each_range[Set]: .: (0.003135) test: #each_range[empty]: .: (0.001970) test: #elements[single number]: .: (0.001453) test: #elements[single range]: .: (0.001740) test: #elements[simple numbers list]: .: (0.001479) test: #elements[numbers and ranges list]: .: (0.001817) test: #elements[just *]: .: (0.001564) test: #elements[range with *]: .: (0.001506) test: #elements[* sorts last]: .: (0.001676) test: #elements[out of order]: .: (0.002326) test: #elements[adjacent]: .: (0.002213) test: #elements[overlapping]: .: (0.002176) test: #elements[contained]: .: (0.001919) test: #elements[multiple *]: .: (0.001641) test: #elements[array]: .: (0.002255) test: #elements[nested array]: .: (0.002407) test: #elements[Set]: .: (0.002011) test: #elements[empty]: .: (0.001388) test: #empty?: .: (0.002988) test: #entries[single number]: .: (0.001564) test: #entries[single range]: .: (0.002249) test: #entries[simple numbers list]: .: (0.001774) test: #entries[numbers and ranges list]: .: (0.002257) test: #entries[just *]: .: (0.001448) test: #entries[range with *]: .: (0.001345) test: #entries[* sorts last]: .: (0.001817) test: #entries[out of order]: .: (0.002184) test: #entries[adjacent]: .: (0.002654) test: #entries[overlapping]: .: (0.002788) test: #entries[contained]: .: (0.002276) test: #entries[multiple *]: .: (0.001710) test: #entries[array]: .: (0.002215) test: #entries[nested array]: .: (0.002595) test: #entries[Set]: .: (0.001826) test: #entries[empty]: .: (0.001110) test: #find_index: .: (0.053811) test: #find_ordered_index: .: (0.020751) test: #freeze: .: (0.002525) test: #freeze makes ractor sharable (deeply frozen):.: (0.001617) test: #full?: .: (0.002048) test: #has_duplicates?[single number]: .: (0.001745) test: #has_duplicates?[single range]: .: (0.001582) test: #has_duplicates?[simple numbers list]: .: (0.002168) test: #has_duplicates?[numbers and ranges list]: .: (0.001983) test: #has_duplicates?[just *]: .: (0.001745) test: #has_duplicates?[range with *]: .: (0.001792) test: #has_duplicates?[* sorts last]: .: (0.001738) test: #has_duplicates?[out of order]: .: (0.002310) test: #has_duplicates?[adjacent]: .: (0.002154) test: #has_duplicates?[overlapping]: .: (0.002235) test: #has_duplicates?[contained]: .: (0.001999) test: #has_duplicates?[multiple *]: .: (0.002072) test: #has_duplicates?[array]: .: (0.001980) test: #has_duplicates?[nested array]: .: (0.002237) test: #has_duplicates?[Set]: .: (0.001820) test: #has_duplicates?[empty]: .: (0.001477) test: #include?: .: (0.409789) test: #include_star?: .: (0.002594) test: #intersect?: .: (0.004364) test: #intersection: .: (0.006120) test: #limit: .: (0.005550) test: #limit with *: .: (0.007156) test: #limit with empty result: .: (0.002281) test: #max: .: (0.013694) test: #merge: .: (0.009677) test: #min: .: (0.007049) test: #minmax: .: (0.006066) test: #normalize[single number]: .: (0.001716) test: #normalize[single range]: .: (0.001561) test: #normalize[simple numbers list]: .: (0.001610) test: #normalize[numbers and ranges list]: .: (0.001890) test: #normalize[just *]: .: (0.001495) test: #normalize[range with *]: .: (0.001894) test: #normalize[* sorts last]: .: (0.001880) test: #normalize[out of order]: .: (0.002110) test: #normalize[adjacent]: .: (0.002028) test: #normalize[overlapping]: .: (0.001815) test: #normalize[contained]: .: (0.002118) test: #normalize[multiple *]: .: (0.001656) test: #normalize[array]: .: (0.002506) test: #normalize[nested array]: .: (0.002727) test: #normalize[Set]: .: (0.001897) test: #normalize[empty]: .: (0.001351) test: #normalize![single number]: .: (0.001591) test: #normalize![single range]: .: (0.001604) test: #normalize![simple numbers list]: .: (0.001469) test: #normalize![numbers and ranges list]: .: (0.001696) test: #normalize![just *]: .: (0.001488) test: #normalize![range with *]: .: (0.001711) test: #normalize![* sorts last]: .: (0.001646) test: #normalize![out of order]: .: (0.001834) test: #normalize![adjacent]: .: (0.002193) test: #normalize![overlapping]: .: (0.002002) test: #normalize![contained]: .: (0.003115) test: #normalize![multiple *]: .: (0.001781) test: #normalize![array]: .: (0.002094) test: #normalize![nested array]: .: (0.002461) test: #normalize![Set]: .: (0.001913) test: #normalize![empty]: .: (0.001304) test: #normalized_string[single number]: .: (0.001520) test: #normalized_string[single range]: .: (0.001595) test: #normalized_string[simple numbers list]: .: (0.001647) test: #normalized_string[numbers and ranges list]: .: (0.002171) test: #normalized_string[just *]: .: (0.001515) test: #normalized_string[range with *]: .: (0.001698) test: #normalized_string[* sorts last]: .: (0.002009) test: #normalized_string[out of order]: .: (0.001766) test: #normalized_string[adjacent]: .: (0.001974) test: #normalized_string[overlapping]: .: (0.001828) test: #normalized_string[contained]: .: (0.001796) test: #normalized_string[multiple *]: .: (0.001792) test: #normalized_string[array]: .: (0.002461) test: #normalized_string[nested array]: .: (0.002365) test: #normalized_string[Set]: .: (0.002047) test: #normalized_string[empty]: .: (0.001153) test: #numbers[single number]: .: (0.002017) test: #numbers[single range]: .: (0.001783) test: #numbers[simple numbers list]: .: (0.001826) test: #numbers[numbers and ranges list]: .: (0.002066) test: #numbers[just *]: .: (0.001537) test: #numbers[range with *]: .: (0.001978) test: #numbers[* sorts last]: .: (0.001874) test: #numbers[out of order]: .: (0.001889) test: #numbers[adjacent]: .: (0.002009) test: #numbers[overlapping]: .: (0.001826) test: #numbers[contained]: .: (0.001911) test: #numbers[multiple *]: .: (0.001955) test: #numbers[array]: .: (0.002755) test: #numbers[nested array]: .: (0.003004) test: #numbers[Set]: .: (0.002607) test: #numbers[empty]: .: (0.001421) test: #ordered_at(negative index): .: (0.012675) test: #ordered_at(non-negative index): .: (0.011136) test: #ranges[single number]: .: (0.001468) test: #ranges[single range]: .: (0.001717) test: #ranges[simple numbers list]: .: (0.001500) test: #ranges[numbers and ranges list]: .: (0.001881) test: #ranges[just *]: .: (0.001429) test: #ranges[range with *]: .: (0.001593) test: #ranges[* sorts last]: .: (0.001786) test: #ranges[out of order]: .: (0.001777) test: #ranges[adjacent]: .: (0.001884) test: #ranges[overlapping]: .: (0.001807) test: #ranges[contained]: .: (0.001938) test: #ranges[multiple *]: .: (0.002078) test: #ranges[array]: .: (0.002547) test: #ranges[nested array]: .: (0.002203) test: #ranges[Set]: .: (0.002172) test: #ranges[empty]: .: (0.001483) test: #slice!: .: (0.013661) test: #string[single number]: .: (0.001542) test: #string[single range]: .: (0.001551) test: #string[simple numbers list]: .: (0.001474) test: #string[numbers and ranges list]: .: (0.001802) test: #string[just *]: .: (0.001443) test: #string[range with *]: .: (0.001403) test: #string[* sorts last]: .: (0.001441) test: #string[out of order]: .: (0.002067) test: #string[adjacent]: .: (0.002360) test: #string[overlapping]: .: (0.001675) test: #string[contained]: .: (0.001772) test: #string[multiple *]: .: (0.001628) test: #string[array]: .: (0.002023) test: #string[nested array]: .: (0.002759) test: #string[Set]: .: (0.001988) test: #string[empty]: .: (0.001240) test: #subtract: .: (0.013053) test: #to_s[single number]: .: (0.001387) test: #to_s[single range]: .: (0.001649) test: #to_s[simple numbers list]: .: (0.001743) test: #to_s[numbers and ranges list]: .: (0.002099) test: #to_s[just *]: .: (0.001288) test: #to_s[range with *]: .: (0.001437) test: #to_s[* sorts last]: .: (0.001582) test: #to_s[out of order]: .: (0.001998) test: #to_s[adjacent]: .: (0.001995) test: #to_s[overlapping]: .: (0.001862) test: #to_s[contained]: .: (0.002211) test: #to_s[multiple *]: .: (0.001745) test: #to_s[array]: .: (0.002524) test: #to_s[nested array]: .: (0.002479) test: #to_s[Set]: .: (0.002001) test: #to_s[empty]: .: (0.001284) test: #to_sequence_set: .: (0.002670) test: #valid_string[single number]: .: (0.001583) test: #valid_string[single range]: .: (0.001736) test: #valid_string[simple numbers list]: .: (0.001854) test: #valid_string[numbers and ranges list]: .: (0.001950) test: #valid_string[just *]: .: (0.001434) test: #valid_string[range with *]: .: (0.001393) test: #valid_string[* sorts last]: .: (0.001491) test: #valid_string[out of order]: .: (0.001686) test: #valid_string[adjacent]: .: (0.001867) test: #valid_string[overlapping]: .: (0.001963) test: #valid_string[contained]: .: (0.001940) test: #valid_string[multiple *]: .: (0.001960) test: #valid_string[array]: .: (0.002120) test: #valid_string[nested array]: .: (0.002418) test: #valid_string[Set]: .: (0.002005) test: #valid_string[empty]: .: (0.001331) test: #xor: .: (0.010143) test: #~ and #complement[single number]: .: (0.002563) test: #~ and #complement[single range]: .: (0.002146) test: #~ and #complement[simple numbers list]: .: (0.002348) test: #~ and #complement[numbers and ranges list]: .: (0.002434) test: #~ and #complement[just *]: .: (0.002313) test: #~ and #complement[range with *]: .: (0.002404) test: #~ and #complement[* sorts last]: .: (0.002535) test: #~ and #complement[out of order]: .: (0.002564) test: #~ and #complement[adjacent]: .: (0.002759) test: #~ and #complement[overlapping]: .: (0.002462) test: #~ and #complement[contained]: .: (0.003148) test: #~ and #complement[multiple *]: .: (0.003255) test: #~ and #complement[array]: .: (0.002766) test: #~ and #complement[nested array]: .: (0.003120) test: #~ and #complement[Set]: .: (0.002400) test: #~ and #complement[empty]: .: (0.001447) test: .[] must not be empty: .: (0.005123) test: .[] returns ractor sharable (deeply frozen): .: (0.001708) test: .[frozen SequenceSet] returns that SequenceSet: .: (0.003795) test: .new, input may be empty: .: (0.003218) test: .new, input must be valid: .: (0.010579) test: .try_convert: .: (0.003553) test: Net::IMAP::SequenceSet(set): .: (0.009814) test: SequenceSet[input][single number]: .: (0.002056) test: SequenceSet[input][single range]: .: (0.001861) test: SequenceSet[input][simple numbers list]: .: (0.002029) test: SequenceSet[input][numbers and ranges list]: .: (0.002519) test: SequenceSet[input][just *]: .: (0.001962) test: SequenceSet[input][range with *]: .: (0.001844) test: SequenceSet[input][* sorts last]: .: (0.002077) test: SequenceSet[input][out of order]: .: (0.002127) test: SequenceSet[input][adjacent]: .: (0.002482) test: SequenceSet[input][overlapping]: .: (0.002472) test: SequenceSet[input][contained]: .: (0.023837) test: SequenceSet[input][multiple *]: .: (0.001934) test: SequenceSet[input][array]: .: (0.002604) test: SequenceSet[input][nested array]: .: (0.002673) test: SequenceSet[input][Set]: .: (0.002301) test: SequenceSet[input][empty]: .: (0.001477) test: frozen error message[#clear]: .: (0.003137) test: frozen error message[#replace seq]: .: (0.002996) test: frozen error message[#replace num]: .: (0.002654) test: frozen error message[#replace str]: .: (0.002585) test: frozen error message[#string=]: .: (0.002250) test: frozen error message[#add]: .: (0.002775) test: frozen error message[#add?]: .: (0.002665) test: frozen error message[#<<]: .: (0.002746) test: frozen error message[#append]: .: (0.002869) test: frozen error message[#delete]: .: (0.002312) test: frozen error message[#delete?]: .: (0.002834) test: frozen error message[#delete_at]: .: (0.002583) test: frozen error message[#slice!]: .: (0.003014) test: frozen error message[#merge]: .: (0.002515) test: frozen error message[#subtract]: .: (0.002767) test: frozen error message[#limit!]: .: (0.002234) test: frozen error message[#complement!]: .: (0.003039) test: frozen error message[#normalize!]: .: (0.002480) test: fuzz test: add numbers and compare to reference Set: .: (2.789643) test: fuzz test: add ranges and compare to reference Set: .: (1.819184) test: fuzz test: set complement identities: .: (0.187749) test: fuzz test: set intersection identities: .: (0.507153) test: fuzz test: set subtraction identities: .: (0.676630) test: fuzz test: set union identities: .: (0.618236) test: fuzz test: set xor identities: .: (0.776485) test: set + other: .: (0.011601) test: set - other: .: (0.020928) test: set == ~~set[single number]: .: (0.003245) test: set == ~~set[single range]: .: (0.003245) test: set == ~~set[simple numbers list]: .: (0.002571) test: set == ~~set[numbers and ranges list]: .: (0.003012) test: set == ~~set[just *]: .: (0.002784) test: set == ~~set[range with *]: .: (0.002436) test: set == ~~set[* sorts last]: .: (0.003154) test: set == ~~set[out of order]: .: (0.003400) test: set == ~~set[adjacent]: .: (0.005269) test: set == ~~set[overlapping]: .: (0.003359) test: set == ~~set[contained]: .: (0.003604) test: set == ~~set[multiple *]: .: (0.003258) test: set == ~~set[array]: .: (0.004502) test: set == ~~set[nested array]: .: (0.003582) test: set == ~~set[Set]: .: (0.003570) test: set == ~~set[empty]: .: (0.002574) test: set | ~set == full[single number]: .: (0.002810) test: set | ~set == full[single range]: .: (0.002229) test: set | ~set == full[simple numbers list]: .: (0.003260) test: set | ~set == full[numbers and ranges list]: .: (0.002998) test: set | ~set == full[just *]: .: (0.002282) test: set | ~set == full[range with *]: .: (0.003700) test: set | ~set == full[* sorts last]: .: (0.002986) test: set | ~set == full[out of order]: .: (0.002918) test: set | ~set == full[adjacent]: .: (0.002936) test: set | ~set == full[overlapping]: .: (0.003741) test: set | ~set == full[contained]: .: (0.003231) test: set | ~set == full[multiple *]: .: (0.002322) test: set | ~set == full[array]: .: (0.003653) test: set | ~set == full[nested array]: .: (0.004776) test: set | ~set == full[Set]: .: (0.003823) test: set | ~set == full[empty]: .: (0.002133) test: transforms keep frozen status[#min(count)]: .: (0.004971) test: transforms keep frozen status[#max(count)]: .: (0.003019) test: transforms keep frozen status[#slice(length)]:.: (0.004681) test: transforms keep frozen status[#slice(range)]: .: (0.005905) test: transforms keep frozen status[#slice => empty]: .: (0.003153) test: transforms keep frozen status[#slice => empty]: .: (0.002967) test: transforms keep frozen status[#union]: .: (0.004343) test: transforms keep frozen status[#intersection]: .: (0.003953) test: transforms keep frozen status[#difference]: .: (0.003171) test: transforms keep frozen status[#xor]: .: (0.005800) test: transforms keep frozen status[#complement]: .: (0.002808) test: transforms keep frozen status[#normalize]: .: (0.003016) test: transforms keep frozen status[#above]: .: (0.003545) test: transforms keep frozen status[#below]: .: (0.003686) test: transforms keep frozen status[#limit]: .: (0.003097) test: transforms keep frozen status[#limit => empty]: .: (0.003493) test: values for '*': .: (0.007598) test: ~full == empty: .: (0.004537) test_inspect[empty]: .: (0.001494) test_inspect[frozen empty]: .: (0.001232) test_inspect[normalized]: .: (0.002054) test_inspect[denormalized]: .: (0.001767) test_inspect[star]: .: (0.002208) test_inspect[frozen]: .: (0.001609) test_inspect[at limit]: .: (0.026786) test_inspect[just over limit]: .: (0.021292) test_inspect[denormalized at limit]: .: (0.030797) test_inspect[over limit]: .: (0.077230) test_inspect[frozen over limit]: .: (0.112142) test_inspect[denormalized over limit]: .: (0.058745) IMAPStoreTest: test: #store with FETCH responses: .: (0.217774) test: #store with unchangedsince: .: (0.169684) test: #uid_store with UIDFETCH responses: .: (0.213953) test: #uid_store with changedsince: .: (0.167518) IMAPTest: test: send PartialRange args: .: (0.439688) test: send literal args: .: (0.518304) test: send non-synchronizing literal that's too large for LITERAL-: .: (0.024908) test: send non-synchronizing literal without known server support: .: (0.108634) test: send non-synchronizing literals with LITERAL+:.: (0.262227) test_append: .: (0.206825) test_append_fail: .: (0.173313) test_connection_closed_during_idle: .: (0.118598) test_connection_closed_without_greeting: .: (0.385091) test_default_port: .: (0.001801) test_disconnect: .: (0.117000) test_exception_during_idle: .: (0.210222) test_exception_during_shutdown: .: (0.118274) test_id: .: (0.233908) test_idle: .: (0.207843) test_idle_done_not_during_idle: .: (0.209768) test_idle_timeout: .: (0.364131) test_imaps_post_connection_check: .: (0.203011) test_imaps_unknown_ca: .: (0.197616) test_imaps_verify_none: .: (0.295294) test_imaps_with_ca_file: .: (0.300308) test_raw_data: .: (0.213418) test_send_invalid_number: .: (0.527202) test_send_symbol_as_flag: .: (0.116969) test_starttls: .: (0.234181) test_starttls_stripping: .: (0.128009) test_starttls_stripping_ok_sent_before_response: .: (0.137675) test_starttls_unknown_ca: .: (0.227259) test_unexpected_bye: .: (0.115186) test_unexpected_eof: .: (0.116217) IMAPUIDPlusTest: test_uidplus_appenduid: .: (0.217248) test_uidplus_copyuid_multiple: .: (0.167388) test_uidplus_copyuid_single: .: (0.163272) test_uidplus_uidnotsticky: .: (0.196923) Net::IMAP::TestData: test_define: .: (0.004511) test_define_edge_cases: .: (0.002314) test_define_with_block: .: (0.001647) test_dup: .: (0.001830) test_eql: .: (0.001713) test_equal: .: (0.001587) test_initialize: .: (0.004988) test_initialize_redefine: .: (0.002380) test_inspect: .: (0.002770) test_instance_behavior: .: (0.003647) test_marshal: .: (0.002086) test_member_precedence: .: (0.001857) test_memberless: .: (0.002255) test_recursive_inspect: .: (0.002552) test_square_braces: .: (0.001799) test_subclass_can_create: .: (0.001999) test_subclass_class_method: .: (0.001133) test_subclass_override_deconstruct: .: (0.001466) test_with: .: (0.006364) ResponseParserTest: test: APPENDUID with '*': .: (0.005917) test: APPENDUID with parser_use_deprecated_uidplus_data = :up_to_max_size: .: (0.006137) test: APPENDUID with parser_use_deprecated_uidplus_data = false: .: (0.003096) test: APPENDUID with parser_use_deprecated_uidplus_data = true: .: (0.011202) test: COPYUID with '*': .: (0.003593) test: COPYUID with backwards ranges: .: (0.004781) test: COPYUID with parser_use_deprecated_uidplus_data = :up_to_max_size: .: (0.008079) test: COPYUID with parser_use_deprecated_uidplus_data = false: .: (0.004902) test: COPYUID with parser_use_deprecated_uidplus_data = true: .: (0.017626) test: config can be passed in to #initialize: .: (0.001355) test: config will inherits from passed in frozen config: .: (0.003013) test: default config inherits from Config.global: .: (0.001840) test: passing in global config inherits from Config.global: .: (0.001729) test_NAMESPACE_rfc2342_example_5.1: .: (0.003602) test_NAMESPACE_rfc2342_example_5.2: .: (0.002677) test_NAMESPACE_rfc2342_example_5.3: .: (0.003169) test_NAMESPACE_rfc2342_example_5.4: .: (0.005586) test_NAMESPACE_rfc2342_example_5.5: .: (0.002764) test_NAMESPACE_rfc2342_example_5.6: .: (0.003941) test_NAMESPACE_rfc2342_example_5.7: .: (0.003086) test_NAMESPACE_rfc2342_example_5.9: .: (0.003610) test_NAMESPACE_rfc9051_6.3.10_example_8: .: (0.003590) test_RFC7162 CONDSTORE 3.1.10. Example 19 (Interaction with ESEARCH): .: (0.004519) test_RFC7162 CONDSTORE 3.1.10. Example 20 (Interaction with ESEARCH): .: (0.003744) test_RFC7162 CONDSTORE 3.1.2.1. HIGHESTMODSEQ Response Code:.: (0.002503) test_RFC7162 CONDSTORE 3.1.2.2. NOMODSEQ Response Code: .: (0.002502) test_RFC7162 CONDSTORE 3.1.3. Example 3 (FETCH MODSEQ): .: (0.002623) test_RFC7162 CONDSTORE 3.1.3. Example 4 (FETCH MODSEQ): .: (0.002549) test_RFC7162 CONDSTORE 3.1.3. Example 6 (MODIFIED Response Code): .: (0.002977) test_RFC7162 CONDSTORE 3.1.5. MODSEQ Search Criterion in SEARCH: .: (0.004017) test_RFC7162 CONDSTORE 3.1.7. HIGHESTMODSEQ Status Data Items: .: (0.003563) test_RFC7162 QRESYNC 3.2.5.1. Modification Sequence and UID Parameters: .: (0.003041) test_RFC7162 QRESYNC 3.2.7. EXPUNGE Command: .: (0.002912) test_RFC9394 PARTIAL 3.1. example 1: .: (0.004258) test_RFC9394 PARTIAL 3.1. example 2: .: (0.004404) test_RFC9394 PARTIAL 3.1. example 3: .: (0.003554) test_RFC9586 UIDONLY 3. UIDREQUIRED response code: .: (0.002291) test_RFC9586 UIDONLY 3.3 UIDFETCH response: .: (0.002623) test_acl_response: .: (0.003082) test_bodystructure_bug11128_ext_mpart_without_lang: .: (0.014114) test_bodystructure_bug7146_msg_delivery_status: .: (0.004220) test_bodystructure_bug7147_message_rfc822_attachment: .: (0.008651) test_bodystructure_bug8167_delivery_status_with_extra_data: .: (0.011813) test_bodystructure_extension_fields: .: (0.017966) test_bodystructure_extra_space: .: (0.010538) test_bodystructure_mixed_boundary: .: (0.013938) test_continuation_request_without_response_text: .: (0.001900) test_fetch_binary_and_binary_size: .: (0.013805) test_fetch_msg_att_HEADER.FIELDS: .: (0.004230) test_fetch_msg_att_HEADER.FIELDS.NOT: .: (0.005517) test_fetch_msg_att_HEADER.FIELDS_quoted: .: (0.003794) test_fetch_msg_att_X-GM-LABELS_1: .: (0.004194) test_fetch_msg_att_X-GM-LABELS_2: .: (0.002426) test_fetch_msg_att_X-GM-LABELS_3: .: (0.003105) test_fetch_msg_att_X-GM-MSGID: .: (0.002351) test_fetch_msg_att_X-GM-THRID: .: (0.002215) test_fetch_msg_att_flags_and_uid: .: (0.002282) test_fetch_msg_att_modseq: .: (0.002803) test_fetch_msg_att_rfc822: .: (0.002476) test_fetch_msg_att_uid: .: (0.002574) test_flags_with_various_flag_types: .: (0.002650) test_greenmail sent "\*" in a FLAGS response: .: (0.002299) test_id_gmail: .: (0.004067) test_id_rfc2971_example_3.1_nil: .: (0.002201) test_id_rfc2971_example_3.2_cyrus: .: (0.005551) test_imaginary_status_response_using_tagged-ext-val:.: (0.007387) test_imap.gmail.com allows invalid atom-specials in flags: .: (0.003030) test_invalid literal numeric format (too large): .: (0.003181) test_invalid_bodystructure_bug7153_mixed: .: (0.003526) test_invalid_bodystructure_message_sent_as_basic: .: (0.012130) test_invalid_capability_extra_space_at_end: .: (0.003632) test_invalid_fetch_msg_att_extra_space: .: (0.002700) test_invalid_fetch_msg_att_rfc822_with_brackets: .: (0.002931) test_invalid_fetch_msg_att_unknown_fails: .: (0.002495) test_invalid_noop_response_is_ignored: .: (0.002604) test_invalid_noop_response_with_numeric_prefix: .: (0.002398) test_invalid_noop_response_with_numeric_prefix_and_unparseable_data:.: (0.002807) test_invalid_noop_response_with_unparseable_data: .: (0.002380) test_invalid_search_response_multiple_result_with_trailing_space: .: (0.002953) test_invalid_search_response_single_result_with_trailing_space: .: (0.002366) test_invalid_status_response_trailing_space: .: (0.002927) test_invalid_thread_empty_response: .: (0.002413) test_list_with_various_flag_capitalizations: .: (0.003079) test_literal numeric formatted with zero-prefix: .: (0.003209) test_outlook.com puts an extra SP in ENVELOPE address lists:.: (0.009801) test_resp-cond-auth_without_SP_resp-text: .: (0.002150) test_resp-cond-bye_without_SP_resp-text: .: (0.002057) test_resp-cond-state_without_SP_resp-text: .: (0.001950) test_resp_code_ALREADYEXISTS_rfc9051_7.1_example: .: (0.002414) test_resp_code_APPENDUID_rfc9051_6.3.12_example: .: (0.003554) test_resp_code_APPENDUID_with_MULTIAPPEND_compatibility: .: (0.004151) test_resp_code_AUTHENTICATIONFAILED_rfc9051_7.1_example: .: (0.002521) test_resp_code_AUTHORIZATIONFAILED_rfc9051_7.1_example_1: .: (0.002389) test_resp_code_AUTHORIZATIONFAILED_rfc9051_7.1_example_2: .: (0.002422) test_resp_code_BADCHARSET_rfc9051_6.4.4.4_example_modified: .: (0.002355) test_resp_code_BADCHARSET_with_astrings: .: (0.003058) test_resp_code_CANNOT_rfc9051_7.1_example: .: (0.002781) test_resp_code_CAPABILITY_rfc9051_6.2.2_example: .: (0.003277) test_resp_code_CAPABILITY_with_valid_atoms: .: (0.003365) test_resp_code_CLIENTBUG_rfc9051_7.1_example: .: (0.002489) test_resp_code_CLOSED: .: (0.002164) test_resp_code_CONTACTADMIN_rfc9051_7.1_example: .: (0.002079) test_resp_code_COPYUID_rfc9051_6.3.12_example: .: (0.004943) test_resp_code_COPYUID_with_reversed_ranges_and_mixed_case: .: (0.004768) test_resp_code_CORRUPTION_rfc9051_7.1_example: .: (0.002020) test_resp_code_EXPIRED_rfc9051_7.1_example: .: (0.002299) test_resp_code_EXPUNGEISSUED_rfc9051_7.1_example: .: (0.002104) test_resp_code_HASCHILDREN_rfc9051_7.1_example: .: (0.002391) test_resp_code_INUSE_rfc9051_7.1_example: .: (0.002300) test_resp_code_LIMIT_rfc9051_7.1_example: .: (0.002306) test_resp_code_NONEXISTENT_rfc9051_7.1_example: .: (0.002230) test_resp_code_NOPERM_rfc9051_7.1_example: .: (0.002157) test_resp_code_OVERQUOTA_rfc9051_7.1_example_1: .: (0.002176) test_resp_code_OVERQUOTA_rfc9051_7.1_example_2: .: (0.002190) test_resp_code_PERMANENTFLAGS_rfc3501_6.3.1_example:.: (0.002544) test_resp_code_PERMANENTFLAGS_rfc3501_6.3.2_example:.: (0.002401) test_resp_code_PRIVACYREQUIRED_rfc9051_7.1_example: .: (0.002455) test_resp_code_READ-ONLY_rfc3501_6.3.2_example: .: (0.002443) test_resp_code_READ-WRITE_rfc3501_6.3.1_example: .: (0.002621) test_resp_code_SERVERBUG_rfc9051_7.1_example: .: (0.002666) test_resp_code_UIDNEXT_rfc3501_6.3.1_example: .: (0.002296) test_resp_code_UIDVALIDITY_rfc3501_6.3.1_example: .: (0.002476) test_resp_code_UNAVAILABLE_rfc9051_7.1_example: .: (0.002388) test_resp_code_UNSEEN_rfc3501_6.3.1_example: .: (0.002552) test_resp_text_PERMANENTFLAGS_with_various_flag_types: .: (0.002302) test_resp_text_with_T_LBRA: .: (0.002588) test_response-tagged_without_SP_resp-text: .: (0.002131) test_rfc3501_6.1.1_example_1_capability_response: .: (0.002645) test_rfc3501_6.1.1_example_2_capability_response: .: (0.002575) test_rfc3501_6.2.2_example_continuation_request: .: (0.002423) test_rfc3501_6.3.11_example_continuation_request: .: (0.002064) test_rfc3501_7.1.1_OK_response_example_1: .: (0.001890) test_rfc3501_7.1.1_OK_response_example_2: .: (0.002947) test_rfc3501_7.1.1_OK_response_example_3: .: (0.001928) test_rfc3501_7.1.2_NO_response_example_1: .: (0.002746) test_rfc3501_7.1.2_NO_response_example_4: .: (0.002108) test_rfc3501_7.1.3_BAD_response_example: .: (0.002449) test_rfc3501_7.1.4_PREAUTH_response_example: .: (0.002179) test_rfc3501_7.1.5_BYE_response_example: .: (0.002334) test_rfc3501_7.2.1_CAPABILITY_response_example: .: (0.002708) test_rfc3501_7.2.2_LIST_response_example: .: (0.002390) test_rfc3501_7.2.3_LSUB_response_example: .: (0.002626) test_rfc3501_7.2.4_STATUS_response_example: .: (0.002872) test_rfc3501_7.2.5_SEARCH_response_example: .: (0.002244) test_rfc3501_7.2.6_FLAGS_response_example: .: (0.002544) test_rfc3501_7.3.1_EXISTS_response_example: .: (0.002383) test_rfc3501_7.3.2_RECENT_response_example: .: (0.002231) test_rfc3501_7.4.1_EXPUNGE_response_example: .: (0.002013) test_rfc3501_7.4.2_FETCH_response_example: .: (0.002964) test_rfc3501_7.5_continuation_request_example: .: (0.001803) test_rfc3501_8_example_1_UNSEEN_response_code: .: (0.002708) test_rfc3501_8_example_2_UIDVALIDITY_response_code: .: (0.002490) test_rfc3501_8_example_3_FETCH_ENVELOPE: .: (0.010140) test_rfc3501_8_example_4_FETCH_BODY[HEADER]: .: (0.003063) test_rfc8474_example_4.1_MAILBOXID_response_to_CREATE: .: (0.002755) test_rfc8474_example_4.2_MAILBOXID_untagged_response_to_SELECT: .: (0.002610) test_rfc8474_example_4.3_MAILBOXID_attribute_for_STATUS: .: (0.002765) test_rfc8474_example_5.3_EMAILID_and_THREADID: .: (0.003888) test_rfc8474_example_5.3_no_THREADID_support: .: (0.003288) test_rfc9051_6.4.4.4_ESEARCH_example_1: .: (0.003820) test_rfc9051_6.4.4.4_ESEARCH_example_2: .: (0.004200) test_rfc9051_6.4.4.4_ESEARCH_example_3: .: (0.004675) test_rfc9051_6.4.4.4_ESEARCH_example_4: .: (0.003073) test_rfc9051_6.4.4.4_ESEARCH_example_5: .: (0.002907) test_rfc9051_6.4.4.4_ESEARCH_example_6: .: (0.002915) test_rfc9051_6.4.4.4_ESEARCH_example_7: .: (0.003561) test_rfc9051_6.4.4.4_ESEARCH_example_8: .: (0.003301) test_rfc9051_6.4.4_ESEARCH_example_1: .: (0.003132) test_rfc9051_6.4.4_ESEARCH_example_2: .: (0.013410) test_rfc9051_6.4.4_ESEARCH_example_3: .: (0.002618) test_rfc9051_6.4.4_ESEARCH_example_4: .: (0.003207) test_rfc9051_6.4.4_ESEARCH_example_5: .: (0.004396) test_rfc9051_6.4.4_ESEARCH_example_6: .: (0.002773) test_rfc9051_6.4.4_ESEARCH_example_7: .: (0.003942) test_rfc9051_7.1_ESEARCH_example_1: .: (0.004302) test_rfc9051_7.2.1_ENABLED_example: .: (0.002755) test_rfc9051_7.2.2_capability_example: .: (0.003508) test_rfc9051_7.3.4_ESEARCH_example_1: .: (0.003700) test_rfc9051_7.3.4_ESEARCH_example_2: .: (0.003526) test_rfc9051_7.3.4_ESEARCH_example_3: .: (0.003990) test_rfc9208_4.1.1_example: .: (0.002742) test_rfc9208_4.1.2_example_1: .: (0.002914) test_rfc9208_4.1.2_example_2: .: (0.004612) test_rfc9208_4.1.4_example: .: (0.002943) test_rfc9208_4.2.1_example: .: (0.004816) test_rfc9208_4.2.2_example_1: .: (0.002416) test_rfc9208_4.2.2_example_2: .: (0.003631) test_rfc9208_4.3.1_example_1: .: (0.002576) test_rfc9208_4.3.1_example_2: .: (0.003785) test_search_response_empty: .: (0.002041) test_search_response_multiple_seq_nums_returned: .: (0.002313) test_search_response_single_seq_nums_returned: .: (0.004146) test_search_response_with_condstore_modseq: .: (0.004431) test_status_response_uidnext_uidvalidity: .: (0.002858) test_thread_rfc5256_example1: .: (0.016598) test_thread_rfc5256_example2: .: (0.014580) test_thread_rfc5256_example3: .: (0.002488) test_thread_rfc5256_example4: .: (0.006170) test_thread_rfc5256_example5: .: (0.002876) test_utf8_in_list_mailbox: .: (0.004229) test_utf8_in_resp_text: .: (0.002148) test_xlist_inbox: .: (0.005101) ResponseReaderTest: test: #read_response_buffer: .: (0.015677) test: #read_response_buffer max_response_size straddling CRLF: .: (0.002772) test: #read_response_buffer with invalid literal size[bad_int64]: .: (0.002005) test: #read_response_buffer with max_response_size: .: (0.005052) SASLprepTest: test_saslprep_invalid_inputs: .: (0.331844) test_saslprep_valid_inputs: .: (0.004370) SearchDataTests: test: #== checks modseq: .: (0.002886) test: #== ignores the order of elements: .: (0.001683) test: #inspect: .: (0.001852) test: #modseq: .: (0.001477) test: #to_s: .: (0.002591) test: #to_s(type): .: (0.002624) test: Array[*nz_numbers] != SearchResult[*differently_sorted]: .: (0.001205) test: Array[*nz_numbers] == SearchResult[*nz_numbers, modseq: nz_number]: .: (0.001431) test: SearchResult.new(nz_numbers) == Array.new(nz_numbers):.: (0.002369) test: SearchResult[*nz_numbers, modseq: nz_number] != Array[*nz_numbers]: .: (0.001514) test: SearchResult[*nz_numbers] == Array[*differently_sorted]: .: (0.001632) test: SearchResult[*nz_numbers] == Array[*nz_numbers]: .: (0.002017) StringPrepNamePrepTest: test: ASCII control characters U+0010 U+007F: .: (0.002924) test: ASCII space character U+0020: .: (0.001981) test: Bidi: RandALCat character U+0627 U+0031 U+0628: .: (0.001475) test: Bidi: RandALCat character U+FB38 and LCat characters: .: (0.005710) test: Case folding 8bit U+00DF (german sharp s): .: (0.002133) test: Case folding ASCII U+0043 U+0041 U+0046 U+0045: .: (0.001533) test: Case folding U+0130 (turkish capital I with dot): .: (0.002437) test: Case folding U+1FB7 and normalization: .: (0.001931) test: Case folding U+2121 U+33C6 U+1D7BB: .: (0.001483) test: Case folding multibyte U+0143 U+037A: .: (0.001623) test: Deprecated U+202A: .: (0.002245) test: Display property character U+0341: .: (0.001871) test: Ideographic description character U+2FF5: .: (0.001831) test: Language tagging character U+E0001: .: (0.002013) test: Language tagging character U+E0042: .: (0.001917) test: Larger test (expanding): .: (0.002058) test: Larger test (shrinking): .: (0.002628) test: Left-to-right mark U+200E: .: (0.002207) test: Map to nothing: .: (0.001768) test: Non-ASCII 8bit control character U+0085: .: (0.002396) test: Non-ASCII 8bit space character U+00A0: .: (0.001911) test: Non-ASCII control character U+1D175: .: (0.001908) test: Non-ASCII multibyte control character U+180E: .: (0.001758) test: Non-ASCII multibyte space character U+1680: .: (0.002085) test: Non-ASCII multibyte space character U+2000: .: (0.001893) test: Non-ASCII multibyte space character U+3000: .: (0.002216) test: Non-character code point U+10FFFF: .: (0.001813) test: Non-character code point U+8FFFE: .: (0.002026) test: Non-plain text character U+FFFD: .: (0.001947) test: Normalization of U+006a U+030c U+00A0 U+00AA: .: (0.001474) test: Plane 0 private use character U+F123: .: (0.002059) test: Plane 15 private use character U+F1234: .: (0.001870) test: Plane 16 private use character U+10F234: .: (0.001989) test: Self-reverting case folding U+0390 and normalization: .: (0.001949) test: Self-reverting case folding U+03B0 and normalization: .: (0.001547) test: Self-reverting case folding U+1E96 and normalization: .: (0.002013) test: Self-reverting case folding U+1F56 and normalization: .: (0.001910) test: Zero Width No-Break Space U+FEFF: .: (0.001843) test: Zero Width Space U+200b: .: (0.001999) StringPrepProfilesTest: test_trace_profile_prohibit_ctrl_chars: .: (0.002782) test_trace_profile_prohibit_tagging_chars: .: (0.001788) StringPrepTablesTest: test_rfc3454_table_A_1: .: (9.312836) test_rfc3454_table_B_1: .: (5.089951) test_rfc3454_table_B_2: .: (5.293730) test_rfc3454_table_C_1_1: .: (3.748480) test_rfc3454_table_C_1_2: .: (4.328980) test_rfc3454_table_C_2_1: .: (3.303730) test_rfc3454_table_C_2_2: .: (4.705157) test_rfc3454_table_C_3: .: (6.018826) test_rfc3454_table_C_4: .: (4.624927) test_rfc3454_table_C_5: .: (4.540426) test_rfc3454_table_C_6: .: (4.164619) test_rfc3454_table_C_7: .: (4.219722) test_rfc3454_table_C_8: .: (4.502590) test_rfc3454_table_C_9: .: (4.504971) test_rfc3454_table_D_1: .: (4.438794) test_rfc3454_table_D_2: .: (6.361977) TestAppendUIDData: test: #assigned_uids is converted to SequenceSet: .: (0.005605) test: #assigned_uids must be a valid uid-set: .: (0.006156) test: #size returns the number of UIDs: .: (0.002709) test: #uidvalidity must be valid nz-number: .: (0.004109) TestCopyUIDData: test: #[](source_uid): .: (0.007713) test: #assigned_uid_for(source_uid): .: (0.007900) test: #assigned_uids is converted to SequenceSet: .: (0.004677) test: #assigned_uids must be a valid uid-set: .: (0.009546) test: #each_uid_pair: .: (0.009370) test: #size returns the number of UIDs: .: (0.005000) test: #source_uid_for(assigned_uid): .: (0.006441) test: #source_uids and #assigned_uids must be same size: .: (0.005243) test: #source_uids is converted to SequenceSet: .: (0.004796) test: #source_uids must be valid uid-set: .: (0.007558) test: #uid_mapping for with source_uids in unsorted order: .: (0.003202) test: #uid_mapping maps source_uids to assigned_uids: .: (0.003406) test: #uidvalidity must be valid nz-number: .: (0.005801) TestUIDPlusData: test: #uid_mapping for with source_uids in unsorted order: .: (0.002598) test: #uid_mapping with sorted source_uids: .: (0.001289) ThreadMemberTest: test: #to_sequence_set: .: (0.003632) UIDFetchDataTest: test: #binary(1, 2, 3, offset: 1) returns the BINARY[1.2.3]<1> attr:.: (0.002886) test: #binary_size(1, 2, 3) returns the BINARY.SIZE[1.2.3] attr: .: (0.002746) test: #deconstruct_keys: .: (0.001250) test: #emailid returns EMAILID value (RFC8474: OBJECTID): .: (0.001120) test: #header returns the BODY[HEADER] attr: .: (0.001363) test: #header(1, 2, 3) returns the BODY[1.2.3.HEADER] attr: .: (0.001278) test: #header(1, 2, oFfset: 456) returns the BODY[1.2.HEADER]<456> attr: .: (0.001173) test: #header_fields(*) => BODY[HEADER.FIELDS (*)] attr: .: (0.001639) test: #header_fields(*, offset:) => BODY[part.HEADER.FIELDS (*)]: .: (0.001753) test: #header_fields(*, part:) => BODY[part.HEADER.FIELDS (*)] attr:.: (0.002252) test: #header_fields_not(*) => BODY[HEADER.FIELDS.NOT (*)] attr: .: (0.001628) test: #header_fields_not(*, offset:) => BODY[part.HEADER.FIELDS.NOT (*)]: .: (0.001678) test: #header_fields_not(*, part:) => BODY[part.HEADER.FIELDS.NOT (*)] attr:.: (0.002167) test: #initialize warns when uid differs from attr['UID']: .: (0.001698) test: #internaldate parses a datetime value: .: (0.003059) test: #message returns the BODY[] attr: .: (0.001202) test: #message(offset:) returns the BODY[] attr: .: (0.001151) test: #mime(1, 2, 3) returns the BODY[1.2.3.MIME] attr: .: (0.001258) test: #mime(1, 2, oFfset: 456) returns the BODY[1.2.MIME]<456> attr:.: (0.001284) test: #modseq returns MODSEQ value (RFC7162: CONDSTORE): .: (0.001240) test: #part(1, 2, 3) returns the BODY[1.2.3] attr: .: (0.001124) test: #part(1, 2, oFfset: 456) returns the BODY[1.2]<456> attr: .: (0.002567) test: #seqno does not exist: .: (0.001355) test: #text returns the BODY[TEXT] attr: .: (0.001184) test: #text(1, 2, 3) returns the BODY[1.2.3.TEXT] attr: .: (0.001175) test: #text(1, 2, 3, oFfset: 456) returns the BODY[1.2.3.TEXT]<456> attr: .: (0.001113) test: #threadid returns THREADID value (RFC8474: OBJECTID): .: (0.001407) test: #uid ignores the UID attribute: .: (0.001437) test: #uid replaces #seqno: .: (0.001061) test: simple RFC3501 and RFC9051 attrs accessors: .: (0.002203) test: simple RFC822 attrs accessors (deprecated by RFC9051):.: (0.001200) VanishedDataTest: test: #==: .: (0.003892) test: #deconstruct_keys returns uids and earlier: .: (0.002584) test: #each delegates to uids (SequenceSert#each_number): .: (0.002932) test: #eql?: .: (0.005094) test: #to_a delegates to uids (SequenceSet#numbers):.: (0.001636) test: .[], missing args raises ArgumentError: .: (0.003101) test: .[], mixing args raises ArgumentError: .: (0.002552) test: .[], nil uids raises DataFormatError: .: (0.001895) test: .[uids, earlier]: .: (0.004171) test: .[uids: string, earlier: bool]: .: (0.003071) test: .new allows SequenceSet.empty singleton, not other empty sets:.: (0.002328) test: .new(uids: string, earlier: bool): .: (0.003142) test: .new, missing args raises ArgumentError: .: (0.005684) test: .new, nil uids raises DataFormatError: .: (0.001761) Finished in 114.497240875 seconds. ------------------------------------------------------------------------------- 1327 tests, 11414 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications 100% passed ------------------------------------------------------------------------------- 11.59 tests/s, 99.69 assertions/s >>> ruby-net-imap: Entering fakeroot... /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/authenticators.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/command_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_accessors.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_inheritance.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_type_coercion.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_version_defaults.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/connection_state.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/data_encoding.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/data_lite.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/deprecated_client_options.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/errors.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/esearch_result.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/fetch_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/flags.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_parser.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_parser/parser_utils.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_reader.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/anonymous_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/authentication_exchange.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/authenticators.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/client_adapter.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/cram_md5_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/digest_md5_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/external_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/gs2_header.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/login_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/oauthbearer_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/plain_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/protocol_adapters.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/scram_algorithm.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/scram_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/stringprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/xoauth2_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl_adapter.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/search_result.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sequence_set.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/nameprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/saslprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/saslprep_tables.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/tables.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/trace.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/uidplus_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/vanished_data.rb Successfully installed net-imap-0.5.15 1 gem installed >>> ruby-net-imap-doc*: Running split function doc... 'usr/lib/ruby/gems/3.4.0/doc' -> '/home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap-doc/usr/lib/ruby/gems/3.4.0/doc' >>> ruby-net-imap-doc*: Preparing subpackage ruby-net-imap-doc... >>> ruby-net-imap-doc*: Running postcheck for ruby-net-imap-doc >>> ruby-net-imap*: Running postcheck for ruby-net-imap >>> ruby-net-imap*: Preparing package ruby-net-imap... >>> ruby-net-imap-doc*: Tracing dependencies... ruby >>> ruby-net-imap-doc*: Package size: 1.0 B >>> ruby-net-imap-doc*: Compressing data... >>> ruby-net-imap-doc*: Create checksum... >>> ruby-net-imap-doc*: Create ruby-net-imap-doc-0.5.15-r0.apk >>> ruby-net-imap*: Tracing dependencies... ruby >>> ruby-net-imap*: Package size: 696.5 KB >>> ruby-net-imap*: Compressing data... >>> ruby-net-imap*: Create checksum... >>> ruby-net-imap*: Create ruby-net-imap-0.5.15-r0.apk >>> ruby-net-imap: Build complete at Tue, 27 Oct 2026 09:52:20 +0000 elapsed time 0h 2m 50s >>> ruby-net-imap: Cleaning up srcdir >>> ruby-net-imap: Cleaning up pkgdir >>> ruby-net-imap: Cleaning up tmpdir >>> ruby-net-imap: Uninstalling dependencies... ( 1/13) Purging .makedepends-ruby-net-imap (20261027.094932) ( 2/13) Purging ruby-rdoc (3.4.12-r0) ( 3/13) Purging ruby-base64 (0.2.0-r1) ( 4/13) Purging ruby-rake (13.2.1-r1) ( 5/13) Purging ruby-test-unit (3.6.8-r0) ( 6/13) Purging ruby-power_assert (2.0.5-r0) ( 7/13) Purging ruby-test-unit-ruby-core (1.0.6-r0) ( 8/13) Purging ruby (3.4.12-r0) ( 9/13) Purging ca-certificates (20261020-r0) Executing ca-certificates-20261020-r0.post-deinstall (10/13) Purging libucontext (1.3.3-r0) (11/13) Purging ruby-libs (3.4.12-r0) (12/13) Purging yaml (0.2.5-r2) (13/13) Purging libffi (3.5.2-r0) Executing busybox-1.37.0-r30.trigger OK: 666.6 MiB in 104 packages >>> ruby-net-imap: Updating the main/riscv64 repository index... >>> ruby-net-imap: Signing the index...