>>> ruby-net-imap: Building main/ruby-net-imap 0.5.15-r0 (using abuild 3.17.0-r0) started Tue, 27 Oct 2026 01:35:26 +0000 >>> ruby-net-imap: Validating /home/buildozer/aports/main/ruby-net-imap/APKBUILD... >>> ruby-net-imap: Analyzing dependencies... >>> ruby-net-imap: Installing for build: build-base ruby ruby-rdoc ruby-base64 ruby-rake ruby-test-unit ruby-test-unit-ruby-core ( 1/13) Installing ca-certificates (20261020-r0) ( 2/13) Installing libffi (3.5.2-r1) ( 3/13) Installing yaml (0.2.5-r2) ( 4/13) Installing ruby-libs (3.4.12-r0) ( 5/13) Installing libucontext (1.5.1-r0) ( 6/13) Installing ruby (3.4.12-r0) ( 7/13) Installing ruby-rdoc (3.4.12-r0) ( 8/13) Installing ruby-base64 (0.2.0-r1) ( 9/13) Installing ruby-rake (13.2.1-r1) (10/13) Installing ruby-power_assert (2.0.5-r0) (11/13) Installing ruby-test-unit (3.6.8-r0) (12/13) Installing ruby-test-unit-ruby-core (1.0.6-r0) (13/13) Installing .makedepends-ruby-net-imap (20261027.013527) Executing busybox-1.37.0-r31.trigger Executing ca-certificates-20261020-r0.trigger OK: 684.0 MiB in 118 packages >>> ruby-net-imap: Cleaning up srcdir >>> ruby-net-imap: Cleaning up pkgdir >>> ruby-net-imap: Cleaning up tmpdir >>> ruby-net-imap: Fetching https://distfiles.alpinelinux.org/distfiles/v3.24/net-imap-0.5.15.tar.gz Connecting to distfiles.alpinelinux.org (172.105.82.32:443) wget: server returned error: HTTP/1.1 404 Not Found >>> ruby-net-imap: Fetching https://github.com/ruby/net-imap/archive/v0.5.15/net-imap-0.5.15.tar.gz Connecting to github.com (140.82.121.3:443) Connecting to codeload.github.com (140.82.121.9:443) saving to '/var/cache/distfiles/v3.24/net-imap-0.5.15.tar.gz.part' net-imap-0.5.15.tar. 242k --:--:-- ETA net-imap-0.5.15.tar. 100% |********************************| 313k 0:00:00 ETA '/var/cache/distfiles/v3.24/net-imap-0.5.15.tar.gz.part' saved /var/cache/distfiles/v3.24/net-imap-0.5.15.tar.gz: OK /home/buildozer/aports/main/ruby-net-imap/gemspec.patch: OK >>> ruby-net-imap: Fetching https://distfiles.alpinelinux.org/distfiles/v3.24/net-imap-0.5.15.tar.gz /var/cache/distfiles/v3.24/net-imap-0.5.15.tar.gz: OK /home/buildozer/aports/main/ruby-net-imap/gemspec.patch: OK >>> ruby-net-imap: Unpacking /var/cache/distfiles/v3.24/net-imap-0.5.15.tar.gz... >>> ruby-net-imap: gemspec.patch patching file net-imap.gemspec WARNING: description and summary are identical WARNING: open-ended dependency on net-protocol (>= 0) is not recommended use a bounded requirement, such as "~> x.y" WARNING: open-ended dependency on date (>= 0) is not recommended use a bounded requirement, such as "~> x.y" WARNING: You have specified the uri: https://github.com/ruby/net-imap for all of the following keys: homepage_uri source_code_uri Only the first one will be shown on rubygems.org WARNING: See https://guides.rubygems.org/specification-reference/ for help Successfully built RubyGem Name: net-imap Version: 0.5.15 File: net-imap-0.5.15.gem /home/buildozer/aports/main/ruby-net-imap/src/net-imap-0.5.15/test/lib/profiling_helper.rb:10: warning: method redefined; discarding old profile? /home/buildozer/aports/main/ruby-net-imap/src/net-imap-0.5.15/test/lib/profiling_helper.rb:6: warning: previous definition of profile? was here Loaded suite /usr/lib/ruby/gems/3.4.0/gems/rake-13.2.1/lib/rake/rake_test_loader Started Net::IMAP::TestCase: AuthenticatorsTest: test: .authenticator mechanism name can be a symbol:.: (0.001981) test: .authenticator mechanism name is case insensitive: .: (0.000583) test: SASL::Authenticators.normalize_name: .: (0.000519) test_anonymous_length_over_255: .: (0.001661) test_anonymous_matches_mechanism: .: (0.000604) test_anonymous_response: .: (0.000724) test_anonymous_stringprep: .: (0.001046) test_cram_md5_authenticator: .: (0.002732) test_cram_md5_authenticator_deprecated: .: (0.001046) test_cram_md5_authenticator_matches_mechanism: .: (0.000840) test_cram_md5_does_not_support_initial_response: .: (0.000750) test_digest_md5_authenticator: .: (0.005511) test_digest_md5_authenticator_deprecated: .: (0.001685) test_digest_md5_authenticator_empty_challenge: .: (0.001619) test_digest_md5_authenticator_empty_challenge_commas: .: (0.001894) test_digest_md5_authenticator_empty_qop: .: (0.002343) test_digest_md5_authenticator_garbage: .: (0.001898) test_digest_md5_authenticator_garbage_no_equal_sign:.: (0.002011) test_digest_md5_authenticator_illinear: .: (0.020096) test_digest_md5_authenticator_matches_mechanism: .: (0.001108) test_digest_md5_authenticator_missing_nonce: .: (0.002211) test_digest_md5_authenticator_qdstr_with_comma: .: (0.002030) test_digest_md5_authenticator_realm_and_digest_uri: .: (0.002028) test_digest_md5_does_not_support_initial_response: .: (0.000993) test_external_invalid: .: (0.000714) test_external_matches_mechanism: .: (0.000472) test_external_response: .: (0.000649) test_external_utf8: .: (0.000376) test_login_authenticator_deprecated: .: (0.000561) test_login_authenticator_matches_mechanism: .: (0.000390) test_login_does_not_support_initial_response: .: (0.000346) test_login_responses: .: (0.000459) test_net_imap_authenticator_deprecated: .: (0.000843) test_oauthbearer_authenticator_matches_mechanism: .: (0.000556) test_oauthbearer_response: .: (0.000906) test_plain_authenticator_matches_mechanism: .: (0.000388) test_plain_authzid: .: (0.000390) test_plain_kw_params: .: (0.000415) test_plain_no_null_chars: .: (0.001248) test_plain_response: .: (0.000436) test_plain_supports_initial_response: .: (0.000313) test_plain_username_kw_sets_both_authcid_and_authzid: .: (0.000371) test_scram_kwargs: .: (0.000651) test_scram_max_iterations: .: (0.003293) test_scram_min_iterations: .: (0.002885) test_scram_sha1_authenticator: .: (0.010942) test_scram_sha1_authenticator_matches_mechanism: .: (0.000642) test_scram_sha256_authenticator: .: (0.015027) test_scram_sha256_authenticator_matches_mechanism: .: (0.000625) test_xoauth2_authenticator_matches_mechanism: .: (0.000350) test_xoauth2_kwargs: .: (0.000565) test_xoauth2_response: .: (0.000358) test_xoauth2_supports_initial_response: .: (0.000303) CommandDataTest: test: Atom: .: (0.006316) test: Flag: .: (0.005531) test: Literal: .: (0.001477) test: Literal8: .: (0.000969) QuotedStringTest: test: ASCII compatible string with another encodings: .: (0.001604) test: allows ASCII control chars: .: (0.000539) test: escapes quoted specials: .: (0.000706) test: invalid ASCII byte[NULL]: .: (0.002365) test: invalid ASCII byte[CR]: .: (0.002264) test: invalid ASCII byte[LF]: .: (0.002213) test: invalid UTF-8[incomplete 2 byte sequence]: .: (0.003694) test: invalid UTF-8[invalid 2 byte sequence]: .: (0.002950) test: invalid UTF-8[incomplete 3 byte sequence]: .: (0.002193) test: invalid UTF-8[invalid 3 byte sequence]: .: (0.002060) test: invalid UTF-8[incomplete 4 byte sequence]: .: (0.002640) test: invalid UTF-8[invalid 4 byte sequence]: .: (0.002498) test: invalid UTF-8[first byte too high]: .: (0.002047) test: invalid UTF-8[UTF-16 surrogate pair]: .: (0.002189) test: invalid UTF-8[windows-1252]: .: (0.002082) test: quotes ASCII strings (atom specials): .: (0.001327) test: quotes ASCII strings (no specials): .: (0.000553) test: quotes valid UTF-8 multibyte chars: .: (0.000562) RawDataTest: test: .split[simple raw text]: .: (0.001138) test: .split[text, literal, text]: .: (0.000834) test: .split[empty literals]: .: (0.000849) test: .split[binary and regular]: .: (0.000785) test: .split allows final literal prefix: .: (0.001240) test: a single literal: .: (0.001005) test: binary literal with regular literal: .: (0.001180) test: empty literals: .: (0.000959) test: invalid bytes in raw text[CR]: .: (0.001270) test: invalid bytes in raw text[LF]: .: (0.000988) test: invalid bytes in raw text[NULL]: .: (0.000899) test: invalid bytes in raw text[CRLF]: .: (0.000877) test: invalid literal ending ('{123}'): .: (0.002523) test: literals embedded between text: .: (0.001059) test: raw text embedded between literals: .: (0.000622) test: raw text followed by literal: .: (0.001023) test: simple raw text: .: (0.000659) RawTextTest: test: ASCII compatible string with another encodings: .: (0.001189) test: allows ASCII control chars: .: (0.000467) test: allows ASCII strings with no specials: .: (0.000866) test: allows atom specials: .: (0.000765) test: allows quoted specials: .: (0.000587) test: allows valid UTF-8 multibyte chars: .: (0.000522) test: invalid ASCII byte[NULL]: .: (0.002342) test: invalid ASCII byte[CR]: .: (0.002274) test: invalid ASCII byte[LF]: .: (0.002703) test: invalid UTF-8[incomplete 2 byte sequence]: .: (0.002614) test: invalid UTF-8[invalid 2 byte sequence]: .: (0.002076) test: invalid UTF-8[incomplete 3 byte sequence]: .: (0.003007) test: invalid UTF-8[invalid 3 byte sequence]: .: (0.002996) test: invalid UTF-8[incomplete 4 byte sequence]: .: (0.003272) test: invalid UTF-8[invalid 4 byte sequence]: .: (0.002105) test: invalid UTF-8[first byte too high]: .: (0.002281) test: invalid UTF-8[UTF-16 surrogate pair]: .: (0.002240) test: invalid UTF-8[windows-1252]: .: (0.002452) ConfigTest: test: #clone: .: (0.001693) test: #debug: .: (0.001211) test: #dup: .: (0.000734) test: #freeze: .: (0.001029) test: #inherited? and #reset(attr): .: (0.001058) test: #load_defaults: .: (0.002498) test: #max_response_size=(Integer | nil): .: (0.000885) test: #new and inheritance: .: (0.000915) test: #reset all attributes: .: (0.000599) test: #to_h: .: (0.000682) test: #update: .: (0.000533) test: #update with invalid key name: .: (0.000810) test: #update with invalid value: .: (0.000816) test: #with: .: (0.001062) test: .[] for all version_defaults: .: (0.001097) test: .[] for all x.y versions: .: (0.001647) test: .[] key errors: .: (0.001252) test: .[] range errors: .: (0.001490) test: .[] with a hash: .: (0.000781) test: .[] with object responding to to_sym, to_r, or to_f: .: (0.001124) test: .[] with string names: .: (0.000658) test: .[] with symbol names: .: (0.000732) test: .default: .: (0.000520) test: .global: .: (0.000540) test: .new always sets a parent: .: (0.000949) test: .new(parent, ...) and inheritance: .: (0.001364) test: .version_defaults are all frozen, and inherit debug from global: .: (0.017290) test: Config[:default] and Config[:current] both hold default config: .: (0.000820) test: Net::IMAP.config: .: (0.000382) test: boolean type constraints and conversion: .: (0.000451) test: enum type constraint: .: (0.001038) test: integer type constraints and conversion: .: (0.000706) ConnectionStateTest: test: #authenticated?: .: (0.001247) test: #deconstruct: .: (0.000611) test: #deconstruct_keys: .: (0.000970) test: #logout?: .: (0.000497) test: #name: .: (0.000455) test: #not_authenticated?: .: (0.000447) test: #selected?: .: (0.000420) test: #to_sym: .: (0.000438) DataEncodingTest: test_decode_date: .: (0.001599) test_decode_datetime: .: (0.000994) test_decode_time: .: (0.001113) test_decode_utf7: .: (0.024543) test_encode_date: .: (0.000742) test_encode_datetime: .: (0.000574) test_encode_utf7: .: (0.004768) ESearchResultTest: test: #data.assoc('UNKNOWN') returns ExtensionData value: .: (0.005248) test: #each: .: (0.001614) test: #partial returns PARTIAL value (RFC9394: PARTIAL): .: (0.002102) test: #tag: .: (0.000900) test: #to_a: .: (0.001445) test: #to_sequence_set: .: (0.001614) test: #uid: .: (0.000618) test: simple RFC4731 and RFC9051 return data accessors: .: (0.000766) FetchDataTest: test: #binary(1, 2, 3, offset: 1) returns the BINARY[1.2.3]<1> attr:.: (0.001028) test: #binary_size(1, 2, 3) returns the BINARY.SIZE[1.2.3] attr: .: (0.000496) test: #emailid returns EMAILID value (RFC8474: OBJECTID): .: (0.000765) test: #header returns the BODY[HEADER] attr: .: (0.000385) test: #header(1, 2, 3) returns the BODY[1.2.3.HEADER] attr: .: (0.000316) test: #header(1, 2, oFfset: 456) returns the BODY[1.2.HEADER]<456> attr: .: (0.000340) test: #header_fields(*) => BODY[HEADER.FIELDS (*)] attr: .: (0.000800) test: #header_fields(*, offset:) => BODY[part.HEADER.FIELDS (*)]: .: (0.000466) test: #header_fields(*, part:) => BODY[part.HEADER.FIELDS (*)] attr:.: (0.000608) test: #header_fields_not(*) => BODY[HEADER.FIELDS.NOT (*)] attr: .: (0.000475) test: #header_fields_not(*, offset:) => BODY[part.HEADER.FIELDS.NOT (*)]: .: (0.000485) test: #header_fields_not(*, part:) => BODY[part.HEADER.FIELDS.NOT (*)] attr:.: (0.000558) test: #internaldate parses a datetime value: .: (0.003462) test: #message returns the BODY[] attr: .: (0.000849) test: #message(offset:) returns the BODY[] attr: .: (0.000362) test: #mime(1, 2, 3) returns the BODY[1.2.3.MIME] attr: .: (0.000399) test: #mime(1, 2, oFfset: 456) returns the BODY[1.2.MIME]<456> attr:.: (0.000343) test: #modseq returns MODSEQ value (RFC7162: CONDSTORE): .: (0.000308) test: #part(1, 2, 3) returns the BODY[1.2.3] attr: .: (0.000335) test: #part(1, 2, oFfset: 456) returns the BODY[1.2]<456> attr: .: (0.000382) test: #seqno: .: (0.000332) test: #text returns the BODY[TEXT] attr: .: (0.000355) test: #text(1, 2, 3) returns the BODY[1.2.3.TEXT] attr: .: (0.000320) test: #text(1, 2, 3, oFfset: 456) returns the BODY[1.2.3.TEXT]<456> attr: .: (0.000438) test: #threadid returns THREADID value (RFC8474: OBJECTID): .: (0.000322) test: #uid: .: (0.000409) test: simple RFC3501 and RFC9051 attrs accessors: .: (0.000752) test: simple RFC822 attrs accessors (deprecated by RFC9051):.: (0.000463) IMAPAuthenticateTest: test: #authenticate disconnects and raises SASL::AuthenticationFailed when the server succeeds prematurely: .: (0.060459) test: #authenticate never sends an initial response when config.sasl_ir: false: .: (0.107141) test: #authenticate never sends an initial response when sasl_ir: false: .: (0.105688) test: #authenticate never sends an initial response when the mechanism does not support client-first: .: (0.055615) test: #authenticate never sends an initial response when the server doesn't explicitly support the mechanism: .: (0.063278) test: #authenticate never sends an initial response when the server isn't capable: .: (0.063192) test: #authenticate sends '=' as the initial reponse when the initial response is an empty string: .: (0.130845) test: #authenticate sends an initial response when supported by both the mechanism and the server: .: (0.054490) IMAPCapabilitiesTest: test: #auth_capable?(name) checks cached capabilities for AUTH=name:.: (0.101590) test: #auth_mechanisms reports cached capabilities with AUTH={name}:.: (0.095795) test: #capabilities cache IGNORES tagged OK response to STARTTLS: .: (0.152323) test: #capabilities cache is NOT cleared after #authenticate fails: .: (0.147779) test: #capabilities cache is NOT cleared after #login fails:.: (0.052540) test: #capabilities cache is cleared after #authenticate: .: (0.135459) test: #capabilities cache is cleared after #login: .: (0.367835) test: #capabilities cache is cleared after #starttls: .: (0.143980) test: #capabilities cache is retained after selecting a mailbox: .: (0.095180) test: #capabilities caches greeting capabilities (PREAUTH): .: (0.009798) test: #capabilities caches greeting capabilities (cleartext): .: (0.009948) test: #capabilities caches greeting capabilities (implicit TLS): .: (0.137570) test: #capabilities caches tagged OK response to AUTHENTICATE: .: (0.054371) test: #capabilities caches tagged OK response to LOGIN: .: (0.053504) test: #capabilities returns cached CAPABILITY data: .: (0.110649) test: #capability caches its result: .: (0.091291) test: #capable?(name) checks cached CAPABILITY data for name: .: (0.093881) test: #clear_cached_capabilities clears cached capabilities:.: (0.092538) IMAPConnectionStateTest: test: #connection_state after #disconnect: .: (0.008992) test: #connection_state after #logout: .: (0.009666) test: #connection_state after #logout!: .: (0.010290) test: #connection_state after AUTHENTICATE, SELECT, CLOSE successes:.: (0.179128) test: #connection_state after LOGIN, EXAMINE, UNSELECT successes: .: (0.224986) test: #connection_state after PREAUTH: .: (0.135230) test: #connection_state after [CLOSED] response code: .: (0.218856) test: #connection_state after failed LOGIN or AUTHENTICATE: .: (0.179738) test: #connection_state after failed SELECT or EXAMINE: .: (0.263268) IMAPDeprecatedClientOptionsTest: InitializeTests: test: Convert deprecated usessl (= false) with warning: .: (0.008686) test: Convert deprecated usessl (= true) and certs, with warning: .: (0.139941) test: Convert deprecated usessl (= true) and verify (= false), with warning: .: (0.139682) test: Convert obsolete options hash to keywords: .: (0.007608) test: Convert obsolete port argument to :port keyword: .: (0.007542) test: combined options hash and keyword args raises ArgumentError:.: (0.000985) test: combined options hash and ssl args raises ArgumentError: .: (0.000734) StartTLSTests: test: Convert deprecated certs, verify with warning: .: (0.078460) test: Convert obsolete options hash to keywords: .: (0.060467) test: combined options hash and keyword args raises ArgumentError:.: (0.009362) test: combined options hash and ssl args raises ArgumentError: .: (0.013940) IMAPEnableTest: test: missing server ENABLED response: .: (0.052197) test_enable: .: (0.256506) IMAPErrorsTest: test: ResponseTooLargeError: .: (0.004609) IMAPExpungeTest: test: #expunge with EXPUNGE responses: .: (0.177121) test: #expunge with a VANISHED response: .: (0.180390) test: #expunge with multiple VANISHED responses: .: (0.177538) test: #uid_expunge with EXPUNGE responses: .: (0.176994) test: #uid_expunge with VANISHED response: .: (0.177490) IMAPFetchTest: test: #fetch with FETCH responses: .: (0.180786) test: #fetch with changedsince: .: (0.137342) test: #uid_fetch with UIDFETCH responses: .: (0.183564) test: #uid_fetch with changedsince: .: (0.136479) test: #uid_fetch with partial: .: (0.305019) test: argument errors: .: (0.094403) IMAPLoginTest: test: #login doesn't send CAPABILITY when it is already cached: .: (0.052419) test: #login first checks capabilities for LOGINDISABLED (failure): .: (0.091386) test: #login first checks capabilities for LOGINDISABLED (success): .: (0.132834) test: #login raises LoginDisabledError when LOGINDISABLED: .: (0.009651) test: #login raises LoginDisabledError without sending CAPABILITY when config.enforce_logindisabled is :when_capabilities_cached: .: (0.017091) test: #login sends LOGIN without asking CAPABILITY when config.enforce_logindisabled is :when_capabilities_cached: .: (0.107679) test: #login sends LOGIN without asking CAPABILITY when config.enforce_logindisabled is false: .: (0.053026) IMAPMaxResponseSizeTest: test: #max_response_size closes connection for too long line: .: (0.011789) test: #max_response_size closes connection for too long literal: .: (0.012041) test: #max_response_size reading literals: .: (0.054538) IMAPQuotaTest: test: #setquota(quota_root, limit): .: (0.140586) IMAPRegexpsTest: test_linear_time[Net::IMAP::FakeServer::Socket#ignore_closed?: /stream closed|closed stream/i]: .: (0.001437) test_linear_time[Net::IMAP::FakeServer::CommandReader#get_command: /\{(\d+)(\+)?\}\r\n\z/n]:.: (0.000371) test_linear_time[Net::IMAP::FakeServer::CommandReader#scan_astrings: /"((?:[^"\\]|\\["\\])+)"|(\S+)/n]: .: (0.000309) test_linear_time[Net::IMAP::FakeServer::CommandReader#scan_astrings: /\\([\\"])/n]: .: (0.001384) test_linear_time[Net::IMAP::FakeServer::CommandReader#partial_parse: /\A([^ ]+) ((?:UID )?\w+)(?: (.+))?\r\n\z/min]:.: (0.000420) test_linear_time[Net::IMAP::FakeServer::CommandReader#parse: /\A([^ ]+) ((?:UID )?\w+)(?: (.+))?\r\n\z/min]:.: (0.000294) test_linear_time[Net::IMAP::FakeServer::ResponseWriter#resp_code: /\A\[/]: .: (0.001330) test_linear_time[Net::IMAP::RawData.split: /(~)?\{(0|[1-9]\d*)(\+)?\}\r\n/n]: .: (0.000473) test_linear_time[Net::IMAP::RawData#validate: /\{\d+\+?\}\z/n]: .: (0.000302) test_linear_time[Net::IMAP::StringPrep::Tables::IN_A_1]: .: (0.000338) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_1]: .: (0.001288) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_2]: .: (0.000487) test_linear_time[Net::IMAP::StringPrep::Tables::IN_B_3]: .: (0.000411) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_1_1]: .: (0.000311) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_1_2]: .: (0.000510) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_2_1]: .: (0.000546) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_2_2]: .: (0.000355) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_3]: .: (0.000432) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_4]: .: (0.000312) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_5]: .: (0.000389) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_6]: .: (0.070579) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_7]: .: (0.000452) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_8]: .: (0.000355) test_linear_time[Net::IMAP::StringPrep::Tables::IN_C_9]: .: (0.000299) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_1]: .: (0.000363) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_1_NEGATED]: .: (0.000481) test_linear_time[Net::IMAP::StringPrep::Tables::IN_D_2]: .: (0.000522) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILS_REQ3]: .: (0.000472) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILS_REQ2]: .: (0.000915) test_linear_time[Net::IMAP::StringPrep::Tables::BIDI_FAILURE]: .: (0.001032) test_linear_time[Net::IMAP::StringPrep::SASLprep::MAP_TO_SPACE]: .: (0.000348) test_linear_time[Net::IMAP::StringPrep::SASLprep::MAP_TO_NOTHING]: .: (0.000469) test_linear_time[Net::IMAP::StringPrep::SASLprep::PROHIBITED_STORED]: .: (0.001055) test_linear_time[Net::IMAP::StringPrep::SASLprep::PROHIBITED]: .: (0.000988) test_linear_time[Net::IMAP::StringPrep::SASLprep::ASCII_NO_CTRLS]: .: (0.000407) test_linear_time[Net::IMAP::StringPrep::SASLprep.saslprep: /invalid byte sequence|incompatible encoding/]: .: (0.000499) test_linear_time[Net::IMAP::StringPrep::SASLprep#saslprep: /invalid byte sequence|incompatible encoding/]: .: (0.000339) test_linear_time[Net::IMAP::StringPrep.check_prohibited!: /^C/]: .: (0.000333) test_linear_time[Net::IMAP::StringPrep#check_prohibited!: /^C/]: .: (0.000303) test_linear_time[Net::IMAP::ValidNonLiteralData#validate: /[\r\n]/]:.: (0.000465) test_linear_time[Net::IMAP::SASL::Authenticators#add_authenticator: /[^a-zA-Z0-9]/]:.: (0.000354) test_linear_time[Net::IMAP::SASL::GS2Header::NO_NULL_CHARS]:.: (0.000472) test_linear_time[Net::IMAP::SASL::GS2Header::RFC5801_SASLNAME]: .: (0.000401) test_linear_time[Net::IMAP::SASL::ExternalAuthenticator#initialize: /\u0000/]: .: (0.000309) test_linear_time[Net::IMAP::SASL::ScramAuthenticator#parse_challenge: /,/]: .: (0.000367) test_linear_time[Net::IMAP::SASL::ScramAuthenticator#parse_challenge: /=/]: .: (0.000477) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#process: /rspauth=/]: .: (0.000452) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#compute_a2: /^auth-(?:conf|int)$/]:.: (0.000391) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#parse_challenge: /\A"(.*)"\z/mn]: .: (0.000308) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#parse_challenge: /\\(.)/mn]: .: (0.000313) test_linear_time[Net::IMAP::SASL::DigestMD5Authenticator#qdval: /([\\"])/]: .: (0.000517) test_linear_time[Net::IMAP::QuotedString#formatted: /["\\]/]: .: (0.000334) test_linear_time[Net::IMAP::StringFormatter::LITERAL_REGEX]:.: (0.000346) test_linear_time[Net::IMAP::SequenceSet#number_input?: /[:,]/]: .: (0.000305) test_linear_time[Net::IMAP::SequenceSet#nz_number: /\A[1-9]\d*\z/]: .: (0.000378) test_linear_time[Net::IMAP::Config::AttrAccessors.attributes: /=\z/]: .: (0.000315) test_linear_time[Net::IMAP::ResponseParser::ParserUtils::Generator#def_char_matchers: /\A[A-Z]/]: .: (0.000310) test_linear_time[Net::IMAP::ResponseParser::ParserUtils::Generator#def_token_matchers: /\A[A-Z]/]: .: (0.000473) test_linear_time[Net::IMAP::ResponseParser::ADDRESS_REGEXP]:.: (0.000589) test_linear_time[Net::IMAP::ResponseParser::RE_RESPONSE_TYPE]: .: (0.000381) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE]: .: (0.000698) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::OCTET]: .: (0.000400) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::SP]: .: (0.000320) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CHAR]: .: (0.000346) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::ALPHA]: .: (0.000481) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CTL]:.: (0.000335) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::DIGIT]: .: (0.000291) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::CRLF]: .: (0.000311) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::DQUOTE]: .: (0.000402) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC5234::HEXDIG]: .: (0.000320) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_1]: .: (0.000352) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_TAIL]: .: (0.000458) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_2]: .: (0.000341) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_3]: .: (0.000304) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_4]: .: (0.000321) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_CHAR]: .: (0.000412) test_linear_time[Net::IMAP::ResponseParser::Patterns::RFC3629::UTF8_OCTETS]:.: (0.000345) test_linear_time[Net::IMAP::ResponseParser::Patterns::CHAR8]: .: (0.000371) test_linear_time[Net::IMAP::ResponseParser::Patterns::LIST_WILDCARDS]: .: (0.000428) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_SPECIALS]: .: (0.000556) test_linear_time[Net::IMAP::ResponseParser::Patterns::RESP_SPECIALS]: .: (0.000367) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_SPECIALS]: .: (0.000343) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_CHAR]:.: (0.000303) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM_CHAR]: .: (0.000515) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM]:.: (0.000327) test_linear_time[Net::IMAP::ResponseParser::Patterns::ASTRING_CHARS]: .: (0.000371) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOMISH]: .: (0.000415) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAG]: .: (0.000364) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_CHAR]: .: (0.000338) test_linear_time[Net::IMAP::ResponseParser::Patterns::CODE_TEXT_CHAR]: .: (0.000312) test_linear_time[Net::IMAP::ResponseParser::Patterns::CODE_TEXT]: .: (0.000398) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG]:.: (0.000377) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_EXTENSION]: .: (0.000339) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_KEYWORD]:.: (0.000484) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_PERM]: .: (0.000351) test_linear_time[Net::IMAP::ResponseParser::Patterns::MBX_FLAG]: .: (0.000351) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_LIST]: .: (0.000319) test_linear_time[Net::IMAP::ResponseParser::Patterns::FLAG_PERM_LIST]: .: (0.000418) test_linear_time[Net::IMAP::ResponseParser::Patterns::MBX_LIST_FLAGS]: .: (0.000499) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUIRKY_FLAG]: .: (0.000397) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUIRKY_FLAGS_LIST]: .: (0.000345) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_safe]: .: (0.000295) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_esc]: .: (0.000388) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_rev1]: .: (0.000359) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_CHAR_rev2]: .: (0.000452) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_rev1]: .: (0.000373) test_linear_time[Net::IMAP::ResponseParser::Patterns::QUOTED_rev2]: .: (0.000325) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_rev1]: .: (0.000321) test_linear_time[Net::IMAP::ResponseParser::Patterns::TEXT_rev2]: .: (0.000529) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_LABEL_FCHAR]: .: (0.000331) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_LABEL_CHAR]: .: (0.000382) test_linear_time[Net::IMAP::ResponseParser::Patterns::TAGGED_EXT_LABEL]: .: (0.000302) test_linear_time[Net::IMAP::ResponseParser::Patterns::NZ_NUMBER]: .: (0.000372) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQ_NUMBER]: .: (0.000347) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQ_RANGE]: .: (0.000316) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET_ITEM]: .: (0.000477) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET]:.: (0.000358) test_linear_time[Net::IMAP::ResponseParser::Patterns::SEQUENCE_SET_STR]: .: (0.000621) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE_FIRST]: .: (0.000550) test_linear_time[Net::IMAP::ResponseParser::Patterns::PARTIAL_RANGE_LAST]: .: (0.000447) test_linear_time[Net::IMAP::ResponseParser::Patterns::LITERAL]: .: (0.000333) test_linear_time[Net::IMAP::ResponseParser::Patterns::LITERAL8]: .: (0.000413) test_linear_time[Net::IMAP::ResponseParser::Patterns::ATOM_SPECIALS]: .: (0.000418) test_linear_time[Net::IMAP::ResponseParser::SPACES_REGEXP]: .: (0.000329) test_linear_time[Net::IMAP::ResponseParser::BEG_REGEXP]: .: (0.000381) test_linear_time[Net::IMAP::ResponseParser::DATA_REGEXP]: .: (0.000473) test_linear_time[Net::IMAP::ResponseParser::TEXT_REGEXP]: .: (0.000385) test_linear_time[Net::IMAP::ResponseParser::CTEXT_REGEXP]: .: (0.000354) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABODY\[/in]: .: (0.000318) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABINARY\[/in]:.: (0.000515) test_linear_time[Net::IMAP::ResponseParser#msg_att: /\ABINARY\.SIZE\[/in]: .: (0.000326) test_linear_time[Net::IMAP::ResponseParser#msg_att__label: /\A(?:RFC822(?:\.HEADER|\.TEXT)?)\z/in]: .: (0.000376) test_linear_time[Net::IMAP::ResponseParser#body_type_1part: /\G(?: (? "TEXT" \s "[^"]+" ) |(? "MESSAGE" \s "(?:RFC822|GLOBAL)" ) |(? "[^"]+" \s "[^"]+" ) |(? "MIXED" ) )/ixn]: .: (0.000601) test_linear_time[Net::IMAP::ResponseParser#esearch_response: /\G UID\b/i]: .: (0.000337) test_linear_time[Net::IMAP::ResponseParser#next_token: /\S*/n]: .: (0.000350) test_linear_time[Net::IMAP::ResponseReader#get_literal_size: /\{(\d+)\}\r\n\z/n]: .: (0.000507) test_linear_time[Net::IMAP::TestData#test_memberless: /#/]: .: (0.000373) test_linear_time[Net::IMAP::TestData#test_define_edge_cases: /duplicate member/]: .: (0.000369) test_linear_time[Net::IMAP.decode_utf7: /&([A-Za-z0-9+,]+)?-/n]: .: (0.000327) test_linear_time[Net::IMAP.encode_utf7: /(&)|[^\x20-\x7e]+/]: .: (0.000404) test_linear_time[Net::IMAP#auth_mechanisms: /\AAUTH=/i]: .: (0.000512) test_linear_time[Net::IMAP#enable: / /]: .: (0.000344) test_linear_time[Net::IMAP#put_string: /\n/n]: .: (0.000379) test_linear_time[Net::IMAP#put_string: /\n\z/n]: .: (0.000306) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:OK)\z/in]: .: (0.000405) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:NO)\z/in]: .: (0.000353) test_linear_time[Net::IMAP#get_tagged_response: /\A(?:BAD)\z/in]: .: (0.000314) test_linear_time[Net::IMAP#get_response: /^/n]: .: (0.000397) test_linear_time[Net::IMAP#search_args: /\ACHARSET\b/i]: .: (0.000324) test_linear_time[Net::IMAP#search_args: /\ACHARSET\z/i]: .: (0.000370) test_linear_time[Net::IMAP#send_string_data: /[\r\n]/n]: .: (0.000433) test_linear_time[Net::IMAP#send_string_data: /[(){ \x00-\x1f\x7f%*"\\]/n]: .: (0.000368) test_linear_time[Net::IMAP#send_quoted_string: /["\\]/]: .: (0.000351) IMAPResponseHandlersTest: test: #add_response_handlers: .: (0.234785) test: ::new with response_handlers kwarg: .: (0.093067) IMAPResponsesTest: test: #clear_responses: .: (0.096542) test: #extract_responses: .: (0.099845) test: #responses without type or block: .: (0.015717) test: #responses(&block): .: (0.096199) test: #responses(type, &block): .: (0.095471) test: #responses(type, &nil): .: (0.096894) IMAPSearchTest: test: #search/#uid_search: .: (1.421656) test: #search/#uid_search with ESEARCH or IMAP4rev2:.: (0.104222) test: #search/#uid_search with invalid arguments: .: (0.010916) test: missing server ESEARCH response: .: (0.094084) test: missing server SEARCH response: .: (0.094043) test: missing server SORT response: .: (0.095762) test: missing server THREAD response: .: (0.099270) IMAPSelectTest: test: #examine with condstore: .: (0.097763) test: #select with condstore: .: (0.096903) test_close: .: (0.136559) test_unselect: .: (0.138668) IMAPSequenceSetTest: test: #<<: .: (0.002243) test: #== equality by value (not by identity or representation): .: (0.000977) test: #[negative index]: .: (0.002178) test: #[non-negative index]: .: (0.002525) test: #[range]: .: (0.120956) test: #[start, length]: .: (0.059152) test: #above: .: (0.002759) test: #add: .: (0.001598) test: #add?: .: (0.001970) test: #append: .: (0.002546) test: #at(negative index): .: (0.002158) test: #at(non-negative index): .: (0.001996) test: #below: .: (0.002938) test: #clone: .: (0.001269) test: #clone preserves ractor sharability (deeply frozen): .: (0.000538) test: #count[single number]: .: (0.000443) test: #count[single range]: .: (0.000440) test: #count[simple numbers list]: .: (0.000416) test: #count[numbers and ranges list]: .: (0.000468) test: #count[just *]: .: (0.000680) test: #count[range with *]: .: (0.000456) test: #count[* sorts last]: .: (0.000414) test: #count[out of order]: .: (0.000591) test: #count[adjacent]: .: (0.000696) test: #count[overlapping]: .: (0.000643) test: #count[contained]: .: (0.000545) test: #count[multiple *]: .: (0.000506) test: #count[array]: .: (0.000645) test: #count[nested array]: .: (0.000681) test: #count[Set]: .: (0.000629) test: #count[empty]: .: (0.000433) test: #count_duplicates[single number]: .: (0.000585) test: #count_duplicates[single range]: .: (0.000505) test: #count_duplicates[simple numbers list]: .: (0.000662) test: #count_duplicates[numbers and ranges list]: .: (0.000692) test: #count_duplicates[just *]: .: (0.000464) test: #count_duplicates[range with *]: .: (0.000480) test: #count_duplicates[* sorts last]: .: (0.000574) test: #count_duplicates[out of order]: .: (0.000618) test: #count_duplicates[adjacent]: .: (0.000705) test: #count_duplicates[overlapping]: .: (0.001122) test: #count_duplicates[contained]: .: (0.000779) test: #count_duplicates[multiple *]: .: (0.000651) test: #count_duplicates[array]: .: (0.000864) test: #count_duplicates[nested array]: .: (0.000771) test: #count_duplicates[Set]: .: (0.000625) test: #count_duplicates[empty]: .: (0.000316) test: #count_with_duplicates[single number]: .: (0.000515) test: #count_with_duplicates[single range]: .: (0.000465) test: #count_with_duplicates[simple numbers list]: .: (0.000500) test: #count_with_duplicates[numbers and ranges list]: .: (0.000618) test: #count_with_duplicates[just *]: .: (0.000392) test: #count_with_duplicates[range with *]: .: (0.000437) test: #count_with_duplicates[* sorts last]: .: (0.000630) test: #count_with_duplicates[out of order]: .: (0.000683) test: #count_with_duplicates[adjacent]: .: (0.000725) test: #count_with_duplicates[overlapping]: .: (0.000684) test: #count_with_duplicates[contained]: .: (0.000695) test: #count_with_duplicates[multiple *]: .: (0.000895) test: #count_with_duplicates[array]: .: (0.000853) test: #count_with_duplicates[nested array]: .: (0.000631) test: #count_with_duplicates[Set]: .: (0.000687) test: #count_with_duplicates[empty]: .: (0.000348) test: #cover?: .: (0.020944) test: #deconstruct[single number]: .: (0.000586) test: #deconstruct[single range]: .: (0.000451) test: #deconstruct[simple numbers list]: .: (0.000585) test: #deconstruct[numbers and ranges list]: .: (0.000581) test: #deconstruct[just *]: .: (0.000414) test: #deconstruct[range with *]: .: (0.000462) test: #deconstruct[* sorts last]: .: (0.000498) test: #deconstruct[out of order]: .: (0.000625) test: #deconstruct[adjacent]: .: (0.000744) test: #deconstruct[overlapping]: .: (0.000754) test: #deconstruct[contained]: .: (0.001234) test: #deconstruct[multiple *]: .: (0.000491) test: #deconstruct[array]: .: (0.000786) test: #deconstruct[nested array]: .: (0.000750) test: #deconstruct[Set]: .: (0.000654) test: #deconstruct[empty]: .: (0.000346) test: #delete: .: (0.003471) test: #delete?: .: (0.003094) test: #delete_at: .: (0.001565) test: #disjoint?: .: (0.001257) test: #dup: .: (0.001090) test: #each_element[single number]: .: (0.000747) test: #each_element[single range]: .: (0.000644) test: #each_element[simple numbers list]: .: (0.000684) test: #each_element[numbers and ranges list]: .: (0.000850) test: #each_element[just *]: .: (0.000665) test: #each_element[range with *]: .: (0.000622) test: #each_element[* sorts last]: .: (0.000684) test: #each_element[out of order]: .: (0.000781) test: #each_element[adjacent]: .: (0.000867) test: #each_element[overlapping]: .: (0.000781) test: #each_element[contained]: .: (0.000832) test: #each_element[multiple *]: .: (0.001093) test: #each_element[array]: .: (0.001226) test: #each_element[nested array]: .: (0.001124) test: #each_element[Set]: .: (0.000918) test: #each_element[empty]: .: (0.000527) test: #each_entry[single number]: .: (0.000831) test: #each_entry[single range]: .: (0.000804) test: #each_entry[simple numbers list]: .: (0.000873) test: #each_entry[numbers and ranges list]: .: (0.001119) test: #each_entry[just *]: .: (0.000620) test: #each_entry[range with *]: .: (0.000663) test: #each_entry[* sorts last]: .: (0.000768) test: #each_entry[out of order]: .: (0.001561) test: #each_entry[adjacent]: .: (0.001500) test: #each_entry[overlapping]: .: (0.001305) test: #each_entry[contained]: .: (0.001158) test: #each_entry[multiple *]: .: (0.000873) test: #each_entry[array]: .: (0.001264) test: #each_entry[nested array]: .: (0.001286) test: #each_entry[Set]: .: (0.001167) test: #each_entry[empty]: .: (0.000540) test: #each_number[single number]: .: (0.000628) test: #each_number[single range]: .: (0.000592) test: #each_number[simple numbers list]: .: (0.000646) test: #each_number[numbers and ranges list]: .: (0.001186) test: #each_number[just *]: .: (0.000869) test: #each_number[range with *]: .: (0.000687) test: #each_number[* sorts last]: .: (0.000811) test: #each_number[out of order]: .: (0.000870) test: #each_number[adjacent]: .: (0.000842) test: #each_number[overlapping]: .: (0.000900) test: #each_number[contained]: .: (0.000812) test: #each_number[multiple *]: .: (0.000803) test: #each_number[array]: .: (0.001026) test: #each_number[nested array]: .: (0.001147) test: #each_number[Set]: .: (0.000995) test: #each_number[empty]: .: (0.000678) test: #each_ordered_number[single number]: .: (0.000790) test: #each_ordered_number[single range]: .: (0.001241) test: #each_ordered_number[simple numbers list]: .: (0.000991) test: #each_ordered_number[numbers and ranges list]:.: (0.001120) test: #each_ordered_number[just *]: .: (0.000800) test: #each_ordered_number[range with *]: .: (0.000751) test: #each_ordered_number[* sorts last]: .: (0.000824) test: #each_ordered_number[out of order]: .: (0.001208) test: #each_ordered_number[adjacent]: .: (0.001547) test: #each_ordered_number[overlapping]: .: (0.001340) test: #each_ordered_number[contained]: .: (0.001176) test: #each_ordered_number[multiple *]: .: (0.000896) test: #each_ordered_number[array]: .: (0.001147) test: #each_ordered_number[nested array]: .: (0.001191) test: #each_ordered_number[Set]: .: (0.001427) test: #each_ordered_number[empty]: .: (0.000614) test: #each_range[single number]: .: (0.000682) test: #each_range[single range]: .: (0.000586) test: #each_range[simple numbers list]: .: (0.000702) test: #each_range[numbers and ranges list]: .: (0.000742) test: #each_range[just *]: .: (0.000565) test: #each_range[range with *]: .: (0.000581) test: #each_range[* sorts last]: .: (0.000616) test: #each_range[out of order]: .: (0.000882) test: #each_range[adjacent]: .: (0.000878) test: #each_range[overlapping]: .: (0.000993) test: #each_range[contained]: .: (0.000735) test: #each_range[multiple *]: .: (0.000698) test: #each_range[array]: .: (0.001016) test: #each_range[nested array]: .: (0.001152) test: #each_range[Set]: .: (0.001018) test: #each_range[empty]: .: (0.000530) test: #elements[single number]: .: (0.000485) test: #elements[single range]: .: (0.000416) test: #elements[simple numbers list]: .: (0.000468) test: #elements[numbers and ranges list]: .: (0.000559) test: #elements[just *]: .: (0.000525) test: #elements[range with *]: .: (0.000417) test: #elements[* sorts last]: .: (0.000768) test: #elements[out of order]: .: (0.000690) test: #elements[adjacent]: .: (0.000559) test: #elements[overlapping]: .: (0.000579) test: #elements[contained]: .: (0.000523) test: #elements[multiple *]: .: (0.000456) test: #elements[array]: .: (0.000763) test: #elements[nested array]: .: (0.000847) test: #elements[Set]: .: (0.000682) test: #elements[empty]: .: (0.000430) test: #empty?: .: (0.000819) test: #entries[single number]: .: (0.000550) test: #entries[single range]: .: (0.000460) test: #entries[simple numbers list]: .: (0.000545) test: #entries[numbers and ranges list]: .: (0.000738) test: #entries[just *]: .: (0.000474) test: #entries[range with *]: .: (0.000425) test: #entries[* sorts last]: .: (0.000487) test: #entries[out of order]: .: (0.000784) test: #entries[adjacent]: .: (0.001241) test: #entries[overlapping]: .: (0.000908) test: #entries[contained]: .: (0.000685) test: #entries[multiple *]: .: (0.000552) test: #entries[array]: .: (0.000634) test: #entries[nested array]: .: (0.000786) test: #entries[Set]: .: (0.000686) test: #entries[empty]: .: (0.000365) test: #find_index: .: (0.029555) test: #find_ordered_index: .: (0.005365) test: #freeze: .: (0.000944) test: #freeze makes ractor sharable (deeply frozen):.: (0.000512) test: #full?: .: (0.000618) test: #has_duplicates?[single number]: .: (0.000506) test: #has_duplicates?[single range]: .: (0.000462) test: #has_duplicates?[simple numbers list]: .: (0.000553) test: #has_duplicates?[numbers and ranges list]: .: (0.000791) test: #has_duplicates?[just *]: .: (0.000539) test: #has_duplicates?[range with *]: .: (0.000503) test: #has_duplicates?[* sorts last]: .: (0.000559) test: #has_duplicates?[out of order]: .: (0.000720) test: #has_duplicates?[adjacent]: .: (0.000810) test: #has_duplicates?[overlapping]: .: (0.000783) test: #has_duplicates?[contained]: .: (0.000741) test: #has_duplicates?[multiple *]: .: (0.000598) test: #has_duplicates?[array]: .: (0.000724) test: #has_duplicates?[nested array]: .: (0.000821) test: #has_duplicates?[Set]: .: (0.000688) test: #has_duplicates?[empty]: .: (0.000386) test: #include?: .: (0.122597) test: #include_star?: .: (0.000932) test: #intersect?: .: (0.001172) test: #intersection: .: (0.001767) test: #limit: .: (0.001729) test: #limit with *: .: (0.002035) test: #limit with empty result: .: (0.000679) test: #max: .: (0.003308) test: #merge: .: (0.002750) test: #min: .: (0.001933) test: #minmax: .: (0.001411) test: #normalize[single number]: .: (0.000590) test: #normalize[single range]: .: (0.000469) test: #normalize[simple numbers list]: .: (0.000577) test: #normalize[numbers and ranges list]: .: (0.000654) test: #normalize[just *]: .: (0.000445) test: #normalize[range with *]: .: (0.000462) test: #normalize[* sorts last]: .: (0.000478) test: #normalize[out of order]: .: (0.000556) test: #normalize[adjacent]: .: (0.000717) test: #normalize[overlapping]: .: (0.000628) test: #normalize[contained]: .: (0.000608) test: #normalize[multiple *]: .: (0.000507) test: #normalize[array]: .: (0.000786) test: #normalize[nested array]: .: (0.000964) test: #normalize[Set]: .: (0.000784) test: #normalize[empty]: .: (0.000338) test: #normalize![single number]: .: (0.000451) test: #normalize![single range]: .: (0.000478) test: #normalize![simple numbers list]: .: (0.000521) test: #normalize![numbers and ranges list]: .: (0.000513) test: #normalize![just *]: .: (0.000441) test: #normalize![range with *]: .: (0.000381) test: #normalize![* sorts last]: .: (0.000500) test: #normalize![out of order]: .: (0.000648) test: #normalize![adjacent]: .: (0.000750) test: #normalize![overlapping]: .: (0.000677) test: #normalize![contained]: .: (0.000608) test: #normalize![multiple *]: .: (0.000473) test: #normalize![array]: .: (0.000677) test: #normalize![nested array]: .: (0.000703) test: #normalize![Set]: .: (0.000699) test: #normalize![empty]: .: (0.000344) test: #normalized_string[single number]: .: (0.000562) test: #normalized_string[single range]: .: (0.000486) test: #normalized_string[simple numbers list]: .: (0.000477) test: #normalized_string[numbers and ranges list]: .: (0.000664) test: #normalized_string[just *]: .: (0.000453) test: #normalized_string[range with *]: .: (0.000541) test: #normalized_string[* sorts last]: .: (0.000523) test: #normalized_string[out of order]: .: (0.000640) test: #normalized_string[adjacent]: .: (0.000784) test: #normalized_string[overlapping]: .: (0.000622) test: #normalized_string[contained]: .: (0.000536) test: #normalized_string[multiple *]: .: (0.000438) test: #normalized_string[array]: .: (0.000928) test: #normalized_string[nested array]: .: (0.000926) test: #normalized_string[Set]: .: (0.000768) test: #normalized_string[empty]: .: (0.000336) test: #numbers[single number]: .: (0.000456) test: #numbers[single range]: .: (0.000497) test: #numbers[simple numbers list]: .: (0.000439) test: #numbers[numbers and ranges list]: .: (0.000496) test: #numbers[just *]: .: (0.000526) test: #numbers[range with *]: .: (0.000516) test: #numbers[* sorts last]: .: (0.000675) test: #numbers[out of order]: .: (0.000559) test: #numbers[adjacent]: .: (0.000621) test: #numbers[overlapping]: .: (0.000652) test: #numbers[contained]: .: (0.000593) test: #numbers[multiple *]: .: (0.000640) test: #numbers[array]: .: (0.000858) test: #numbers[nested array]: .: (0.001085) test: #numbers[Set]: .: (0.000942) test: #numbers[empty]: .: (0.000416) test: #ordered_at(negative index): .: (0.003658) test: #ordered_at(non-negative index): .: (0.003213) test: #ranges[single number]: .: (0.000593) test: #ranges[single range]: .: (0.000457) test: #ranges[simple numbers list]: .: (0.000490) test: #ranges[numbers and ranges list]: .: (0.000667) test: #ranges[just *]: .: (0.000510) test: #ranges[range with *]: .: (0.000456) test: #ranges[* sorts last]: .: (0.000478) test: #ranges[out of order]: .: (0.000676) test: #ranges[adjacent]: .: (0.000697) test: #ranges[overlapping]: .: (0.000640) test: #ranges[contained]: .: (0.000599) test: #ranges[multiple *]: .: (0.000470) test: #ranges[array]: .: (0.000778) test: #ranges[nested array]: .: (0.000873) test: #ranges[Set]: .: (0.000725) test: #ranges[empty]: .: (0.000376) test: #slice!: .: (0.003888) test: #string[single number]: .: (0.000550) test: #string[single range]: .: (0.000445) test: #string[simple numbers list]: .: (0.000540) test: #string[numbers and ranges list]: .: (0.000575) test: #string[just *]: .: (0.000359) test: #string[range with *]: .: (0.000490) test: #string[* sorts last]: .: (0.000624) test: #string[out of order]: .: (0.000675) test: #string[adjacent]: .: (0.000698) test: #string[overlapping]: .: (0.000662) test: #string[contained]: .: (0.000562) test: #string[multiple *]: .: (0.000461) test: #string[array]: .: (0.000718) test: #string[nested array]: .: (0.000725) test: #string[Set]: .: (0.000731) test: #string[empty]: .: (0.000377) test: #subtract: .: (0.003587) test: #to_s[single number]: .: (0.000603) test: #to_s[single range]: .: (0.000375) test: #to_s[simple numbers list]: .: (0.000473) test: #to_s[numbers and ranges list]: .: (0.000530) test: #to_s[just *]: .: (0.000342) test: #to_s[range with *]: .: (0.000381) test: #to_s[* sorts last]: .: (0.000391) test: #to_s[out of order]: .: (0.000581) test: #to_s[adjacent]: .: (0.000630) test: #to_s[overlapping]: .: (0.000635) test: #to_s[contained]: .: (0.000560) test: #to_s[multiple *]: .: (0.000496) test: #to_s[array]: .: (0.000724) test: #to_s[nested array]: .: (0.000762) test: #to_s[Set]: .: (0.000663) test: #to_s[empty]: .: (0.000419) test: #to_sequence_set: .: (0.000678) test: #valid_string[single number]: .: (0.000480) test: #valid_string[single range]: .: (0.000426) test: #valid_string[simple numbers list]: .: (0.000622) test: #valid_string[numbers and ranges list]: .: (0.000556) test: #valid_string[just *]: .: (0.000347) test: #valid_string[range with *]: .: (0.000370) test: #valid_string[* sorts last]: .: (0.000431) test: #valid_string[out of order]: .: (0.000466) test: #valid_string[adjacent]: .: (0.000575) test: #valid_string[overlapping]: .: (0.000579) test: #valid_string[contained]: .: (0.000536) test: #valid_string[multiple *]: .: (0.000545) test: #valid_string[array]: .: (0.000836) test: #valid_string[nested array]: .: (0.000902) test: #valid_string[Set]: .: (0.000700) test: #valid_string[empty]: .: (0.000451) test: #xor: .: (0.003027) test: #~ and #complement[single number]: .: (0.000852) test: #~ and #complement[single range]: .: (0.000733) test: #~ and #complement[simple numbers list]: .: (0.000855) test: #~ and #complement[numbers and ranges list]: .: (0.000804) test: #~ and #complement[just *]: .: (0.000607) test: #~ and #complement[range with *]: .: (0.000683) test: #~ and #complement[* sorts last]: .: (0.000702) test: #~ and #complement[out of order]: .: (0.000894) test: #~ and #complement[adjacent]: .: (0.000864) test: #~ and #complement[overlapping]: .: (0.000849) test: #~ and #complement[contained]: .: (0.000934) test: #~ and #complement[multiple *]: .: (0.000682) test: #~ and #complement[array]: .: (0.000967) test: #~ and #complement[nested array]: .: (0.001034) test: #~ and #complement[Set]: .: (0.000962) test: #~ and #complement[empty]: .: (0.000470) test: .[] must not be empty: .: (0.001660) test: .[] returns ractor sharable (deeply frozen): .: (0.000698) test: .[frozen SequenceSet] returns that SequenceSet: .: (0.001393) test: .new, input may be empty: .: (0.001020) test: .new, input must be valid: .: (0.002776) test: .try_convert: .: (0.001605) test: Net::IMAP::SequenceSet(set): .: (0.002693) test: SequenceSet[input][single number]: .: (0.000754) test: SequenceSet[input][single range]: .: (0.000614) test: SequenceSet[input][simple numbers list]: .: (0.000574) test: SequenceSet[input][numbers and ranges list]: .: (0.000695) test: SequenceSet[input][just *]: .: (0.000555) test: SequenceSet[input][range with *]: .: (0.000662) test: SequenceSet[input][* sorts last]: .: (0.000640) test: SequenceSet[input][out of order]: .: (0.000746) test: SequenceSet[input][adjacent]: .: (0.000761) test: SequenceSet[input][overlapping]: .: (0.012459) test: SequenceSet[input][contained]: .: (0.001037) test: SequenceSet[input][multiple *]: .: (0.000723) test: SequenceSet[input][array]: .: (0.000866) test: SequenceSet[input][nested array]: .: (0.000832) test: SequenceSet[input][Set]: .: (0.000815) test: SequenceSet[input][empty]: .: (0.000487) test: frozen error message[#clear]: .: (0.001000) test: frozen error message[#replace seq]: .: (0.000968) test: frozen error message[#replace num]: .: (0.000829) test: frozen error message[#replace str]: .: (0.000871) test: frozen error message[#string=]: .: (0.000808) test: frozen error message[#add]: .: (0.000814) test: frozen error message[#add?]: .: (0.000796) test: frozen error message[#<<]: .: (0.000802) test: frozen error message[#append]: .: (0.000836) test: frozen error message[#delete]: .: (0.004040) test: frozen error message[#delete?]: .: (0.000885) test: frozen error message[#delete_at]: .: (0.000789) test: frozen error message[#slice!]: .: (0.000829) test: frozen error message[#merge]: .: (0.000821) test: frozen error message[#subtract]: .: (0.000876) test: frozen error message[#limit!]: .: (0.000776) test: frozen error message[#complement!]: .: (0.000862) test: frozen error message[#normalize!]: .: (0.000848) test: fuzz test: add numbers and compare to reference Set: .: (1.557488) test: fuzz test: add ranges and compare to reference Set: .: (0.873984) test: fuzz test: set complement identities: .: (0.087039) test: fuzz test: set intersection identities: .: (0.231400) test: fuzz test: set subtraction identities: .: (0.305951) test: fuzz test: set union identities: .: (0.260839) test: fuzz test: set xor identities: .: (0.346010) test: set + other: .: (0.002691) test: set - other: .: (0.004879) test: set == ~~set[single number]: .: (0.000793) test: set == ~~set[single range]: .: (0.000659) test: set == ~~set[simple numbers list]: .: (0.000721) test: set == ~~set[numbers and ranges list]: .: (0.000806) test: set == ~~set[just *]: .: (0.000566) test: set == ~~set[range with *]: .: (0.000608) test: set == ~~set[* sorts last]: .: (0.000762) test: set == ~~set[out of order]: .: (0.000838) test: set == ~~set[adjacent]: .: (0.000886) test: set == ~~set[overlapping]: .: (0.001660) test: set == ~~set[contained]: .: (0.000803) test: set == ~~set[multiple *]: .: (0.000659) test: set == ~~set[array]: .: (0.001010) test: set == ~~set[nested array]: .: (0.001020) test: set == ~~set[Set]: .: (0.000966) test: set == ~~set[empty]: .: (0.000485) test: set | ~set == full[single number]: .: (0.000604) test: set | ~set == full[single range]: .: (0.000577) test: set | ~set == full[simple numbers list]: .: (0.000674) test: set | ~set == full[numbers and ranges list]: .: (0.000789) test: set | ~set == full[just *]: .: (0.000617) test: set | ~set == full[range with *]: .: (0.000593) test: set | ~set == full[* sorts last]: .: (0.001639) test: set | ~set == full[out of order]: .: (0.000790) test: set | ~set == full[adjacent]: .: (0.000803) test: set | ~set == full[overlapping]: .: (0.000758) test: set | ~set == full[contained]: .: (0.000735) test: set | ~set == full[multiple *]: .: (0.000651) test: set | ~set == full[array]: .: (0.000870) test: set | ~set == full[nested array]: .: (0.000918) test: set | ~set == full[Set]: .: (0.000835) test: set | ~set == full[empty]: .: (0.000544) test: transforms keep frozen status[#min(count)]: .: (0.001220) test: transforms keep frozen status[#max(count)]: .: (0.000728) test: transforms keep frozen status[#slice(length)]:.: (0.001105) test: transforms keep frozen status[#slice(range)]: .: (0.001120) test: transforms keep frozen status[#slice => empty]: .: (0.001629) test: transforms keep frozen status[#slice => empty]: .: (0.000646) test: transforms keep frozen status[#union]: .: (0.000895) test: transforms keep frozen status[#intersection]: .: (0.001029) test: transforms keep frozen status[#difference]: .: (0.000874) test: transforms keep frozen status[#xor]: .: (0.001361) test: transforms keep frozen status[#complement]: .: (0.000865) test: transforms keep frozen status[#normalize]: .: (0.000773) test: transforms keep frozen status[#above]: .: (0.000906) test: transforms keep frozen status[#below]: .: (0.000874) test: transforms keep frozen status[#limit]: .: (0.000896) test: transforms keep frozen status[#limit => empty]: .: (0.000689) test: values for '*': .: (0.001342) test: ~full == empty: .: (0.001890) test_inspect[empty]: .: (0.000371) test_inspect[frozen empty]: .: (0.000325) test_inspect[normalized]: .: (0.000515) test_inspect[denormalized]: .: (0.000445) test_inspect[star]: .: (0.000429) test_inspect[frozen]: .: (0.000535) test_inspect[at limit]: .: (0.012847) test_inspect[just over limit]: .: (0.010268) test_inspect[denormalized at limit]: .: (0.012518) test_inspect[over limit]: .: (0.038915) test_inspect[frozen over limit]: .: (0.054002) test_inspect[denormalized over limit]: .: (0.024113) IMAPStoreTest: test: #store with FETCH responses: .: (0.179872) test: #store with unchangedsince: .: (0.137266) test: #uid_store with UIDFETCH responses: .: (0.178731) test: #uid_store with changedsince: .: (0.137788) IMAPTest: test: send PartialRange args: .: (0.391201) test: send literal args: .: (0.466637) test: send non-synchronizing literal that's too large for LITERAL-: .: (0.010180) test: send non-synchronizing literal without known server support: .: (0.060854) test: send non-synchronizing literals with LITERAL+:.: (0.224896) test_append: .: (0.191246) test_append_fail: .: (0.152286) test_connection_closed_during_idle: .: (0.107300) test_connection_closed_without_greeting: .: (0.306739) test_default_port: .: (0.000583) test_disconnect: .: (0.106568) test_exception_during_idle: .: (0.190278) test_exception_during_shutdown: .: (0.106941) test_id: .: (0.213546) test_idle: .: (0.189298) test_idle_done_not_during_idle: .: (0.204934) test_idle_timeout: .: (0.348342) test_imaps_post_connection_check: .: (0.150233) test_imaps_unknown_ca: .: (0.148749) test_imaps_verify_none: .: (0.232937) test_imaps_with_ca_file: .: (0.240730) test_raw_data: .: (0.176740) test_send_invalid_number: .: (0.483448) test_send_symbol_as_flag: .: (0.066865) test_starttls: .: (0.161057) test_starttls_stripping: .: (0.111824) test_starttls_stripping_ok_sent_before_response: .: (0.120323) test_starttls_unknown_ca: .: (0.153570) test_unexpected_bye: .: (0.106000) test_unexpected_eof: .: (0.105698) IMAPUIDPlusTest: test_uidplus_appenduid: .: (0.177816) test_uidplus_copyuid_multiple: .: (0.139487) test_uidplus_copyuid_single: .: (0.135386) test_uidplus_uidnotsticky: .: (0.139578) Net::IMAP::TestData: test_define: .: (0.001546) test_define_edge_cases: .: (0.000638) test_define_with_block: .: (0.000378) test_dup: .: (0.000555) test_eql: .: (0.000555) test_equal: .: (0.000465) test_initialize: .: (0.001235) test_initialize_redefine: .: (0.000694) test_inspect: .: (0.000754) test_instance_behavior: .: (0.001150) test_marshal: .: (0.000663) test_member_precedence: .: (0.000519) test_memberless: .: (0.000642) test_recursive_inspect: .: (0.000789) test_square_braces: .: (0.000408) test_subclass_can_create: .: (0.000463) test_subclass_class_method: .: (0.000284) test_subclass_override_deconstruct: .: (0.000355) test_with: .: (0.001720) ResponseParserTest: test: APPENDUID with '*': .: (0.001977) test: APPENDUID with parser_use_deprecated_uidplus_data = :up_to_max_size: .: (0.002062) test: APPENDUID with parser_use_deprecated_uidplus_data = false: .: (0.001097) test: APPENDUID with parser_use_deprecated_uidplus_data = true: .: (0.004184) test: COPYUID with '*': .: (0.001652) test: COPYUID with backwards ranges: .: (0.001957) test: COPYUID with parser_use_deprecated_uidplus_data = :up_to_max_size: .: (0.002791) test: COPYUID with parser_use_deprecated_uidplus_data = false: .: (0.001555) test: COPYUID with parser_use_deprecated_uidplus_data = true: .: (0.006220) test: config can be passed in to #initialize: .: (0.000468) test: config will inherits from passed in frozen config: .: (0.000814) test: default config inherits from Config.global: .: (0.000464) test: passing in global config inherits from Config.global: .: (0.000395) test_NAMESPACE_rfc2342_example_5.1: .: (0.001201) test_NAMESPACE_rfc2342_example_5.2: .: (0.000955) test_NAMESPACE_rfc2342_example_5.3: .: (0.000999) test_NAMESPACE_rfc2342_example_5.4: .: (0.001731) test_NAMESPACE_rfc2342_example_5.5: .: (0.000927) test_NAMESPACE_rfc2342_example_5.6: .: (0.001328) test_NAMESPACE_rfc2342_example_5.7: .: (0.001149) test_NAMESPACE_rfc2342_example_5.9: .: (0.001099) test_NAMESPACE_rfc9051_6.3.10_example_8: .: (0.001119) test_RFC7162 CONDSTORE 3.1.10. Example 19 (Interaction with ESEARCH): .: (0.001458) test_RFC7162 CONDSTORE 3.1.10. Example 20 (Interaction with ESEARCH): .: (0.001621) test_RFC7162 CONDSTORE 3.1.2.1. HIGHESTMODSEQ Response Code:.: (0.000807) test_RFC7162 CONDSTORE 3.1.2.2. NOMODSEQ Response Code: .: (0.000845) test_RFC7162 CONDSTORE 3.1.3. Example 3 (FETCH MODSEQ): .: (0.001018) test_RFC7162 CONDSTORE 3.1.3. Example 4 (FETCH MODSEQ): .: (0.000824) test_RFC7162 CONDSTORE 3.1.3. Example 6 (MODIFIED Response Code): .: (0.001109) test_RFC7162 CONDSTORE 3.1.5. MODSEQ Search Criterion in SEARCH: .: (0.001123) test_RFC7162 CONDSTORE 3.1.7. HIGHESTMODSEQ Status Data Items: .: (0.001098) test_RFC7162 QRESYNC 3.2.5.1. Modification Sequence and UID Parameters: .: (0.001066) test_RFC7162 QRESYNC 3.2.7. EXPUNGE Command: .: (0.001005) test_RFC9394 PARTIAL 3.1. example 1: .: (0.001425) test_RFC9394 PARTIAL 3.1. example 2: .: (0.001442) test_RFC9394 PARTIAL 3.1. example 3: .: (0.001202) test_RFC9586 UIDONLY 3. UIDREQUIRED response code: .: (0.000863) test_RFC9586 UIDONLY 3.3 UIDFETCH response: .: (0.000874) test_acl_response: .: (0.001092) test_bodystructure_bug11128_ext_mpart_without_lang: .: (0.004072) test_bodystructure_bug7146_msg_delivery_status: .: (0.001463) test_bodystructure_bug7147_message_rfc822_attachment: .: (0.002734) test_bodystructure_bug8167_delivery_status_with_extra_data: .: (0.003628) test_bodystructure_extension_fields: .: (0.005535) test_bodystructure_extra_space: .: (0.003363) test_bodystructure_mixed_boundary: .: (0.004848) test_continuation_request_without_response_text: .: (0.000655) test_fetch_binary_and_binary_size: .: (0.004593) test_fetch_msg_att_HEADER.FIELDS: .: (0.001391) test_fetch_msg_att_HEADER.FIELDS.NOT: .: (0.001643) test_fetch_msg_att_HEADER.FIELDS_quoted: .: (0.001157) test_fetch_msg_att_X-GM-LABELS_1: .: (0.001285) test_fetch_msg_att_X-GM-LABELS_2: .: (0.000890) test_fetch_msg_att_X-GM-LABELS_3: .: (0.000787) test_fetch_msg_att_X-GM-MSGID: .: (0.000845) test_fetch_msg_att_X-GM-THRID: .: (0.000815) test_fetch_msg_att_flags_and_uid: .: (0.000895) test_fetch_msg_att_modseq: .: (0.000946) test_fetch_msg_att_rfc822: .: (0.000889) test_fetch_msg_att_uid: .: (0.000841) test_flags_with_various_flag_types: .: (0.000692) test_greenmail sent "\*" in a FLAGS response: .: (0.000832) test_id_gmail: .: (0.001354) test_id_rfc2971_example_3.1_nil: .: (0.000678) test_id_rfc2971_example_3.2_cyrus: .: (0.001631) test_imaginary_status_response_using_tagged-ext-val:.: (0.002346) test_imap.gmail.com allows invalid atom-specials in flags: .: (0.001275) test_invalid literal numeric format (too large): .: (0.001294) test_invalid_bodystructure_bug7153_mixed: .: (0.001274) test_invalid_bodystructure_message_sent_as_basic: .: (0.003790) test_invalid_capability_extra_space_at_end: .: (0.001219) test_invalid_fetch_msg_att_extra_space: .: (0.000832) test_invalid_fetch_msg_att_rfc822_with_brackets: .: (0.000889) test_invalid_fetch_msg_att_unknown_fails: .: (0.000989) test_invalid_noop_response_is_ignored: .: (0.000955) test_invalid_noop_response_with_numeric_prefix: .: (0.000788) test_invalid_noop_response_with_numeric_prefix_and_unparseable_data:.: (0.000775) test_invalid_noop_response_with_unparseable_data: .: (0.000794) test_invalid_search_response_multiple_result_with_trailing_space: .: (0.000982) test_invalid_search_response_single_result_with_trailing_space: .: (0.000848) test_invalid_status_response_trailing_space: .: (0.000931) test_invalid_thread_empty_response: .: (0.000671) test_list_with_various_flag_capitalizations: .: (0.001103) test_literal numeric formatted with zero-prefix: .: (0.001149) test_outlook.com puts an extra SP in ENVELOPE address lists:.: (0.003058) test_resp-cond-auth_without_SP_resp-text: .: (0.000882) test_resp-cond-bye_without_SP_resp-text: .: (0.000641) test_resp-cond-state_without_SP_resp-text: .: (0.000714) test_resp_code_ALREADYEXISTS_rfc9051_7.1_example: .: (0.000763) test_resp_code_APPENDUID_rfc9051_6.3.12_example: .: (0.001173) test_resp_code_APPENDUID_with_MULTIAPPEND_compatibility: .: (0.001433) test_resp_code_AUTHENTICATIONFAILED_rfc9051_7.1_example: .: (0.000795) test_resp_code_AUTHORIZATIONFAILED_rfc9051_7.1_example_1: .: (0.000825) test_resp_code_AUTHORIZATIONFAILED_rfc9051_7.1_example_2: .: (0.000783) test_resp_code_BADCHARSET_rfc9051_6.4.4.4_example_modified: .: (0.000853) test_resp_code_BADCHARSET_with_astrings: .: (0.001005) test_resp_code_CANNOT_rfc9051_7.1_example: .: (0.000845) test_resp_code_CAPABILITY_rfc9051_6.2.2_example: .: (0.001034) test_resp_code_CAPABILITY_with_valid_atoms: .: (0.001275) test_resp_code_CLIENTBUG_rfc9051_7.1_example: .: (0.000836) test_resp_code_CLOSED: .: (0.000833) test_resp_code_CONTACTADMIN_rfc9051_7.1_example: .: (0.000707) test_resp_code_COPYUID_rfc9051_6.3.12_example: .: (0.001591) test_resp_code_COPYUID_with_reversed_ranges_and_mixed_case: .: (0.001678) test_resp_code_CORRUPTION_rfc9051_7.1_example: .: (0.000821) test_resp_code_EXPIRED_rfc9051_7.1_example: .: (0.000768) test_resp_code_EXPUNGEISSUED_rfc9051_7.1_example: .: (0.000788) test_resp_code_HASCHILDREN_rfc9051_7.1_example: .: (0.000823) test_resp_code_INUSE_rfc9051_7.1_example: .: (0.000780) test_resp_code_LIMIT_rfc9051_7.1_example: .: (0.000744) test_resp_code_NONEXISTENT_rfc9051_7.1_example: .: (0.000822) test_resp_code_NOPERM_rfc9051_7.1_example: .: (0.000789) test_resp_code_OVERQUOTA_rfc9051_7.1_example_1: .: (0.000789) test_resp_code_OVERQUOTA_rfc9051_7.1_example_2: .: (0.000776) test_resp_code_PERMANENTFLAGS_rfc3501_6.3.1_example:.: (0.000847) test_resp_code_PERMANENTFLAGS_rfc3501_6.3.2_example:.: (0.000870) test_resp_code_PRIVACYREQUIRED_rfc9051_7.1_example: .: (0.000779) test_resp_code_READ-ONLY_rfc3501_6.3.2_example: .: (0.000765) test_resp_code_READ-WRITE_rfc3501_6.3.1_example: .: (0.000762) test_resp_code_SERVERBUG_rfc9051_7.1_example: .: (0.000770) test_resp_code_UIDNEXT_rfc3501_6.3.1_example: .: (0.000715) test_resp_code_UIDVALIDITY_rfc3501_6.3.1_example: .: (0.000757) test_resp_code_UNAVAILABLE_rfc9051_7.1_example: .: (0.000821) test_resp_code_UNSEEN_rfc3501_6.3.1_example: .: (0.000819) test_resp_text_PERMANENTFLAGS_with_various_flag_types: .: (0.000776) test_resp_text_with_T_LBRA: .: (0.000809) test_response-tagged_without_SP_resp-text: .: (0.000679) test_rfc3501_6.1.1_example_1_capability_response: .: (0.000871) test_rfc3501_6.1.1_example_2_capability_response: .: (0.000847) test_rfc3501_6.2.2_example_continuation_request: .: (0.000887) test_rfc3501_6.3.11_example_continuation_request: .: (0.000694) test_rfc3501_7.1.1_OK_response_example_1: .: (0.000659) test_rfc3501_7.1.1_OK_response_example_2: .: (0.000827) test_rfc3501_7.1.1_OK_response_example_3: .: (0.000656) test_rfc3501_7.1.2_NO_response_example_1: .: (0.000732) test_rfc3501_7.1.2_NO_response_example_4: .: (0.000647) test_rfc3501_7.1.3_BAD_response_example: .: (0.000761) test_rfc3501_7.1.4_PREAUTH_response_example: .: (0.000658) test_rfc3501_7.1.5_BYE_response_example: .: (0.000652) test_rfc3501_7.2.1_CAPABILITY_response_example: .: (0.000875) test_rfc3501_7.2.2_LIST_response_example: .: (0.000863) test_rfc3501_7.2.3_LSUB_response_example: .: (0.000904) test_rfc3501_7.2.4_STATUS_response_example: .: (0.000932) test_rfc3501_7.2.5_SEARCH_response_example: .: (0.000823) test_rfc3501_7.2.6_FLAGS_response_example: .: (0.000696) test_rfc3501_7.3.1_EXISTS_response_example: .: (0.000683) test_rfc3501_7.3.2_RECENT_response_example: .: (0.000699) test_rfc3501_7.4.1_EXPUNGE_response_example: .: (0.000674) test_rfc3501_7.4.2_FETCH_response_example: .: (0.000978) test_rfc3501_7.5_continuation_request_example: .: (0.000698) test_rfc3501_8_example_1_UNSEEN_response_code: .: (0.000819) test_rfc3501_8_example_2_UIDVALIDITY_response_code: .: (0.000819) test_rfc3501_8_example_3_FETCH_ENVELOPE: .: (0.003233) test_rfc3501_8_example_4_FETCH_BODY[HEADER]: .: (0.001157) test_rfc8474_example_4.1_MAILBOXID_response_to_CREATE: .: (0.000970) test_rfc8474_example_4.2_MAILBOXID_untagged_response_to_SELECT: .: (0.000931) test_rfc8474_example_4.3_MAILBOXID_attribute_for_STATUS: .: (0.000934) test_rfc8474_example_5.3_EMAILID_and_THREADID: .: (0.001018) test_rfc8474_example_5.3_no_THREADID_support: .: (0.000939) test_rfc9051_6.4.4.4_ESEARCH_example_1: .: (0.001320) test_rfc9051_6.4.4.4_ESEARCH_example_2: .: (0.001269) test_rfc9051_6.4.4.4_ESEARCH_example_3: .: (0.001343) test_rfc9051_6.4.4.4_ESEARCH_example_4: .: (0.001333) test_rfc9051_6.4.4.4_ESEARCH_example_5: .: (0.001064) test_rfc9051_6.4.4.4_ESEARCH_example_6: .: (0.001088) test_rfc9051_6.4.4.4_ESEARCH_example_7: .: (0.001146) test_rfc9051_6.4.4.4_ESEARCH_example_8: .: (0.001354) test_rfc9051_6.4.4_ESEARCH_example_1: .: (0.001129) test_rfc9051_6.4.4_ESEARCH_example_2: .: (0.001285) test_rfc9051_6.4.4_ESEARCH_example_3: .: (0.000934) test_rfc9051_6.4.4_ESEARCH_example_4: .: (0.007948) test_rfc9051_6.4.4_ESEARCH_example_5: .: (0.001100) test_rfc9051_6.4.4_ESEARCH_example_6: .: (0.001357) test_rfc9051_6.4.4_ESEARCH_example_7: .: (0.002102) test_rfc9051_7.1_ESEARCH_example_1: .: (0.001502) test_rfc9051_7.2.1_ENABLED_example: .: (0.001725) test_rfc9051_7.2.2_capability_example: .: (0.001683) test_rfc9051_7.3.4_ESEARCH_example_1: .: (0.001724) test_rfc9051_7.3.4_ESEARCH_example_2: .: (0.001445) test_rfc9051_7.3.4_ESEARCH_example_3: .: (0.001733) test_rfc9208_4.1.1_example: .: (0.001181) test_rfc9208_4.1.2_example_1: .: (0.001314) test_rfc9208_4.1.2_example_2: .: (0.002020) test_rfc9208_4.1.4_example: .: (0.001187) test_rfc9208_4.2.1_example: .: (0.002154) test_rfc9208_4.2.2_example_1: .: (0.001042) test_rfc9208_4.2.2_example_2: .: (0.001549) test_rfc9208_4.3.1_example_1: .: (0.000962) test_rfc9208_4.3.1_example_2: .: (0.001885) test_search_response_empty: .: (0.000798) test_search_response_multiple_seq_nums_returned: .: (0.000792) test_search_response_single_seq_nums_returned: .: (0.001774) test_search_response_with_condstore_modseq: .: (0.000961) test_status_response_uidnext_uidvalidity: .: (0.001176) test_thread_rfc5256_example1: .: (0.006872) test_thread_rfc5256_example2: .: (0.005443) test_thread_rfc5256_example3: .: (0.000818) test_thread_rfc5256_example4: .: (0.002049) test_thread_rfc5256_example5: .: (0.001960) test_utf8_in_list_mailbox: .: (0.001046) test_utf8_in_resp_text: .: (0.001011) test_xlist_inbox: .: (0.001964) ResponseReaderTest: test: #read_response_buffer: .: (0.007002) test: #read_response_buffer max_response_size straddling CRLF: .: (0.000893) test: #read_response_buffer with invalid literal size[bad_int64]: .: (0.000765) test: #read_response_buffer with max_response_size: .: (0.001499) SASLprepTest: test_saslprep_invalid_inputs: .: (0.192174) test_saslprep_valid_inputs: .: (0.001336) SearchDataTests: test: #== checks modseq: .: (0.001081) test: #== ignores the order of elements: .: (0.000451) test: #inspect: .: (0.000634) test: #modseq: .: (0.000430) test: #to_s: .: (0.000636) test: #to_s(type): .: (0.000741) test: Array[*nz_numbers] != SearchResult[*differently_sorted]: .: (0.000350) test: Array[*nz_numbers] == SearchResult[*nz_numbers, modseq: nz_number]: .: (0.000515) test: SearchResult.new(nz_numbers) == Array.new(nz_numbers):.: (0.000534) test: SearchResult[*nz_numbers, modseq: nz_number] != Array[*nz_numbers]: .: (0.000343) test: SearchResult[*nz_numbers] == Array[*differently_sorted]: .: (0.000412) test: SearchResult[*nz_numbers] == Array[*nz_numbers]: .: (0.000560) StringPrepNamePrepTest: test: ASCII control characters U+0010 U+007F: .: (0.001049) test: ASCII space character U+0020: .: (0.000737) test: Bidi: RandALCat character U+0627 U+0031 U+0628: .: (0.000515) test: Bidi: RandALCat character U+FB38 and LCat characters: .: (0.002748) test: Case folding 8bit U+00DF (german sharp s): .: (0.000651) test: Case folding ASCII U+0043 U+0041 U+0046 U+0045: .: (0.000508) test: Case folding U+0130 (turkish capital I with dot): .: (0.001057) test: Case folding U+1FB7 and normalization: .: (0.000835) test: Case folding U+2121 U+33C6 U+1D7BB: .: (0.000524) test: Case folding multibyte U+0143 U+037A: .: (0.000476) test: Deprecated U+202A: .: (0.000758) test: Display property character U+0341: .: (0.000642) test: Ideographic description character U+2FF5: .: (0.000559) test: Language tagging character U+E0001: .: (0.000736) test: Language tagging character U+E0042: .: (0.000590) test: Larger test (expanding): .: (0.000633) test: Larger test (shrinking): .: (0.001060) test: Left-to-right mark U+200E: .: (0.000681) test: Map to nothing: .: (0.000501) test: Non-ASCII 8bit control character U+0085: .: (0.000718) test: Non-ASCII 8bit space character U+00A0: .: (0.000552) test: Non-ASCII control character U+1D175: .: (0.000556) test: Non-ASCII multibyte control character U+180E: .: (0.000640) test: Non-ASCII multibyte space character U+1680: .: (0.000578) test: Non-ASCII multibyte space character U+2000: .: (0.000536) test: Non-ASCII multibyte space character U+3000: .: (0.000873) test: Non-character code point U+10FFFF: .: (0.000687) test: Non-character code point U+8FFFE: .: (0.000539) test: Non-plain text character U+FFFD: .: (0.000762) test: Normalization of U+006a U+030c U+00A0 U+00AA: .: (0.000519) test: Plane 0 private use character U+F123: .: (0.000522) test: Plane 15 private use character U+F1234: .: (0.000700) test: Plane 16 private use character U+10F234: .: (0.000787) test: Self-reverting case folding U+0390 and normalization: .: (0.000726) test: Self-reverting case folding U+03B0 and normalization: .: (0.000512) test: Self-reverting case folding U+1E96 and normalization: .: (0.000663) test: Self-reverting case folding U+1F56 and normalization: .: (0.000836) test: Zero Width No-Break Space U+FEFF: .: (0.000544) test: Zero Width Space U+200b: .: (0.000428) StringPrepProfilesTest: test_trace_profile_prohibit_ctrl_chars: .: (0.001269) test_trace_profile_prohibit_tagging_chars: .: (0.000758) StringPrepTablesTest: test_rfc3454_table_A_1: .: (6.021617) test_rfc3454_table_B_1: .: (3.311556) test_rfc3454_table_B_2: .: (3.378062) test_rfc3454_table_C_1_1: .: (2.430753) test_rfc3454_table_C_1_2: .: (3.322855) test_rfc3454_table_C_2_1: .: (2.434227) test_rfc3454_table_C_2_2: .: (3.378881) test_rfc3454_table_C_3: .: (3.791552) test_rfc3454_table_C_4: .: (3.420079) test_rfc3454_table_C_5: .: (3.316793) test_rfc3454_table_C_6: .: (3.294769) test_rfc3454_table_C_7: .: (3.273011) test_rfc3454_table_C_8: .: (3.402239) test_rfc3454_table_C_9: .: (3.336764) test_rfc3454_table_D_1: .: (3.474699) test_rfc3454_table_D_2: .: (4.299271) TestAppendUIDData: test: #assigned_uids is converted to SequenceSet: .: (0.001729) test: #assigned_uids must be a valid uid-set: .: (0.001622) test: #size returns the number of UIDs: .: (0.000956) test: #uidvalidity must be valid nz-number: .: (0.001071) TestCopyUIDData: test: #[](source_uid): .: (0.002439) test: #assigned_uid_for(source_uid): .: (0.002797) test: #assigned_uids is converted to SequenceSet: .: (0.001443) test: #assigned_uids must be a valid uid-set: .: (0.002250) test: #each_uid_pair: .: (0.002914) test: #size returns the number of UIDs: .: (0.001614) test: #source_uid_for(assigned_uid): .: (0.001892) test: #source_uids and #assigned_uids must be same size: .: (0.001253) test: #source_uids is converted to SequenceSet: .: (0.001510) test: #source_uids must be valid uid-set: .: (0.001998) test: #uid_mapping for with source_uids in unsorted order: .: (0.001226) test: #uid_mapping maps source_uids to assigned_uids: .: (0.001165) test: #uidvalidity must be valid nz-number: .: (0.001575) TestUIDPlusData: test: #uid_mapping for with source_uids in unsorted order: .: (0.000898) test: #uid_mapping with sorted source_uids: .: (0.000388) ThreadMemberTest: test: #to_sequence_set: .: (0.001438) UIDFetchDataTest: test: #binary(1, 2, 3, offset: 1) returns the BINARY[1.2.3]<1> attr:.: (0.001084) test: #binary_size(1, 2, 3) returns the BINARY.SIZE[1.2.3] attr: .: (0.001350) test: #deconstruct_keys: .: (0.000516) test: #emailid returns EMAILID value (RFC8474: OBJECTID): .: (0.000314) test: #header returns the BODY[HEADER] attr: .: (0.000337) test: #header(1, 2, 3) returns the BODY[1.2.3.HEADER] attr: .: (0.000362) test: #header(1, 2, oFfset: 456) returns the BODY[1.2.HEADER]<456> attr: .: (0.000334) test: #header_fields(*) => BODY[HEADER.FIELDS (*)] attr: .: (0.000462) test: #header_fields(*, offset:) => BODY[part.HEADER.FIELDS (*)]: .: (0.000421) test: #header_fields(*, part:) => BODY[part.HEADER.FIELDS (*)] attr:.: (0.000608) test: #header_fields_not(*) => BODY[HEADER.FIELDS.NOT (*)] attr: .: (0.000443) test: #header_fields_not(*, offset:) => BODY[part.HEADER.FIELDS.NOT (*)]: .: (0.000416) test: #header_fields_not(*, part:) => BODY[part.HEADER.FIELDS.NOT (*)] attr:.: (0.000590) test: #initialize warns when uid differs from attr['UID']: .: (0.000617) test: #internaldate parses a datetime value: .: (0.001107) test: #message returns the BODY[] attr: .: (0.000438) test: #message(offset:) returns the BODY[] attr: .: (0.000363) test: #mime(1, 2, 3) returns the BODY[1.2.3.MIME] attr: .: (0.000344) test: #mime(1, 2, oFfset: 456) returns the BODY[1.2.MIME]<456> attr:.: (0.000359) test: #modseq returns MODSEQ value (RFC7162: CONDSTORE): .: (0.000301) test: #part(1, 2, 3) returns the BODY[1.2.3] attr: .: (0.000365) test: #part(1, 2, oFfset: 456) returns the BODY[1.2]<456> attr: .: (0.000331) test: #seqno does not exist: .: (0.000488) test: #text returns the BODY[TEXT] attr: .: (0.000349) test: #text(1, 2, 3) returns the BODY[1.2.3.TEXT] attr: .: (0.001181) test: #text(1, 2, 3, oFfset: 456) returns the BODY[1.2.3.TEXT]<456> attr: .: (0.000354) test: #threadid returns THREADID value (RFC8474: OBJECTID): .: (0.000296) test: #uid ignores the UID attribute: .: (0.000321) test: #uid replaces #seqno: .: (0.000293) test: simple RFC3501 and RFC9051 attrs accessors: .: (0.000634) test: simple RFC822 attrs accessors (deprecated by RFC9051):.: (0.000401) VanishedDataTest: test: #==: .: (0.001358) test: #deconstruct_keys returns uids and earlier: .: (0.000777) test: #each delegates to uids (SequenceSert#each_number): .: (0.000997) test: #eql?: .: (0.001332) test: #to_a delegates to uids (SequenceSet#numbers):.: (0.000566) test: .[], missing args raises ArgumentError: .: (0.001218) test: .[], mixing args raises ArgumentError: .: (0.000724) test: .[], nil uids raises DataFormatError: .: (0.000594) test: .[uids, earlier]: .: (0.001050) test: .[uids: string, earlier: bool]: .: (0.001807) test: .new allows SequenceSet.empty singleton, not other empty sets:.: (0.000736) test: .new(uids: string, earlier: bool): .: (0.000953) test: .new, missing args raises ArgumentError: .: (0.001983) test: .new, nil uids raises DataFormatError: .: (0.000631) Finished in 79.097952473 seconds. ------------------------------------------------------------------------------- 1327 tests, 11420 assertions, 0 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications 100% passed ------------------------------------------------------------------------------- 16.78 tests/s, 144.38 assertions/s >>> ruby-net-imap: Entering fakeroot... /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/authenticators.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/command_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_accessors.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_inheritance.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_type_coercion.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/config/attr_version_defaults.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/connection_state.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/data_encoding.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/data_lite.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/deprecated_client_options.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/errors.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/esearch_result.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/fetch_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/flags.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_parser.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_parser/parser_utils.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/response_reader.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/anonymous_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/authentication_exchange.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/authenticators.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/client_adapter.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/cram_md5_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/digest_md5_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/external_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/gs2_header.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/login_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/oauthbearer_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/plain_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/protocol_adapters.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/scram_algorithm.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/scram_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/stringprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl/xoauth2_authenticator.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sasl_adapter.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/search_result.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/sequence_set.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/nameprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/saslprep.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/saslprep_tables.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/tables.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/stringprep/trace.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/uidplus_data.rb /home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap/usr/lib/ruby/gems/3.4.0/gems/net-imap-0.5.15/lib/net/imap/vanished_data.rb Successfully installed net-imap-0.5.15 1 gem installed >>> ruby-net-imap-doc*: Running split function doc... 'usr/lib/ruby/gems/3.4.0/doc' -> '/home/buildozer/aports/main/ruby-net-imap/pkg/ruby-net-imap-doc/usr/lib/ruby/gems/3.4.0/doc' >>> ruby-net-imap-doc*: Preparing subpackage ruby-net-imap-doc... >>> ruby-net-imap-doc*: Running postcheck for ruby-net-imap-doc >>> ruby-net-imap*: Running postcheck for ruby-net-imap >>> ruby-net-imap*: Preparing package ruby-net-imap... >>> ruby-net-imap-doc*: Tracing dependencies... ruby >>> ruby-net-imap-doc*: Package size: 1.0 B >>> ruby-net-imap-doc*: Compressing data... >>> ruby-net-imap-doc*: Create checksum... >>> ruby-net-imap-doc*: Create ruby-net-imap-doc-0.5.15-r0.apk >>> ruby-net-imap*: Tracing dependencies... ruby >>> ruby-net-imap*: Package size: 696.5 KB >>> ruby-net-imap*: Compressing data... >>> ruby-net-imap*: Create checksum... >>> ruby-net-imap*: Create ruby-net-imap-0.5.15-r0.apk >>> ruby-net-imap: Build complete at Tue, 27 Oct 2026 01:37:14 +0000 elapsed time 0h 1m 48s >>> ruby-net-imap: Cleaning up srcdir >>> ruby-net-imap: Cleaning up pkgdir >>> ruby-net-imap: Cleaning up tmpdir >>> ruby-net-imap: Uninstalling dependencies... ( 1/13) Purging .makedepends-ruby-net-imap (20261027.013527) ( 2/13) Purging ruby-rdoc (3.4.12-r0) ( 3/13) Purging ruby-base64 (0.2.0-r1) ( 4/13) Purging ruby-rake (13.2.1-r1) ( 5/13) Purging ruby-test-unit (3.6.8-r0) ( 6/13) Purging ruby-power_assert (2.0.5-r0) ( 7/13) Purging ruby-test-unit-ruby-core (1.0.6-r0) ( 8/13) Purging ruby (3.4.12-r0) ( 9/13) Purging ca-certificates (20261020-r0) Executing ca-certificates-20261020-r0.post-deinstall (10/13) Purging libucontext (1.5.1-r0) (11/13) Purging ruby-libs (3.4.12-r0) (12/13) Purging yaml (0.2.5-r2) (13/13) Purging libffi (3.5.2-r1) Executing busybox-1.37.0-r31.trigger OK: 666.6 MiB in 105 packages >>> ruby-net-imap: Updating the main/riscv64 repository index... >>> ruby-net-imap: Signing the index...